0

Wi-Fi was working before I burned Windows to install Kubuntu 18.04.01 LTS which is working beautifully otherwise with network via ethernet cable.

Here is requested output of lspci -knn | grep Net -A3; rfkill list:

01:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 31)
        Subsystem: Lenovo QCA9377 802.11ac Wireless Network Adapter [17aa:0901]
        Kernel driver in use: ath10k_pci
        Kernel modules: ath10k_pci
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

Here is requested output of dmesg | grep -e wlp -e ath:

[ 17.324157] ath10k_pci 0000:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[ 17.647797] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:01:00.0.bin failed with error -2
[ 17.647823] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/cal-pci-0000:01:00.0.bin failed with error -2
[ 17.650178] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-6.bin failed with error -2
[ 17.660029] ath10k_pci 0000:01:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 17aa:0901
[ 17.660032] ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[ 17.660600] ath10k_pci 0000:01:00.0: firmware ver WLAN.TF.1.0-00002-QCATFSWPZ-5 api 5 features ignore-otp crc32 c3e0d04f
[ 17.937496] ath10k_pci 0000:01:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a
[ 18.599177] ath10k_pci 0000:01:00.0: htt-ver 3.44 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[ 18.606601] ath: EEPROM regdomain: 0x6c
[ 18.606603] ath: EEPROM indicates we should expect a direct regpair map
[ 18.606606] ath: Country alpha2 being used: 00
[ 18.606607] ath: Regpair used: 0x6c
[ 19.080563] ath10k_pci 0000:01:00.0 wlp1s0: renamed from wlan0
[ 25.394600] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[ 26.252659] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[ 26.346138] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready

  • Please edit your question to add the result of the terminal command: dmesg | grep -e wlp -e ath Welcome to Ask Ubuntu. – chili555 Aug 19 '18 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.