0

When I mount a share CIFS share on my machine I can see the content in /run/user/<user ID>/gvfs. That may be because I use a Mate flavour of ubuntu.

In that case I cannot do:

rsync -av path/*  /run/user/<user ID>/gvfs/dest/

it display correctly the list of file but copy doesn't append. however if I

cp -a path/*  /run/user/<user ID>/gvfs/dest/

copy really append and files are now on the share.

Is there something I can do so I can use rsync on the mounted share?

NB: destination samba server is an embeded device, a NETGEAR access point with an USB shared space.

0

In this specific case, it appears that the destination filesystem is some kind of FAT, or vfat, so the creation of temporary file with the format .filename-tmpnumber used by rsync seems to be impossible. So the use of --inplace option of rsync helped me for this. There were a second issue that seems to come from the delta algorithm that is inefficient on such a mount. I finally were able to overcome with the help of --whole-file or short -W

In the end, this works for me:

rsync -avWP --inplace --size-only --no-perms path/*  /run/user/<user ID>/gvfs/dest/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.