3

This issue appeared after upgrading from Ubuntu 16.04 to 18.04.

I have an Intel NUC6i3SYH installed as a headless server on my local network. It has no display and no keyboard attached to it. I control it from my desktop computer, using Remmina. This worked fine when Ubuntu 16.04 was installed on the NUC.

I have now upgraded the NUC to Ubuntu 18.04.01. Suddenly Remmina does not work as intended any more: it can connect to the NUC and asks for the password to get access. But then it only shows a black screen. Remmina only works if I connect a display to the NUC at the time of booting. As long as the NUC senses a display does it provides graphics to Remmina. The graphics in Remmina freeze when removing the display. What do I need to do to have graphics visible in Remmina without having a display connected to the NUC?

Some technical specs about the NUC: NUC6i3SYH, CPU: i3-6100U (formerly called Skylake), using integrated graphics Intel HD Graphics 520.

2
  • 1
    can you ssh into the machine to reinstall remmina? – Joshua Besneatte Aug 19 '18 at 3:58
  • @Joshua Besneatte Remmina is not running on the NUC but on the desktop computer. On the NUC is the setting modified to allow remote connections (default setting is that this is not allowed). – Joe Aug 19 '18 at 4:59
1

I have found a solution which works for the issue I described above. This answer comes from a reply by user Stefan Lemmens (https://askubuntu.com/users/421108/stefan-lemmens) at question: How to use Ubuntu 18.04 on VNC without display attached? His answer involves three steps:

(1) create a 20-intel.conf file, which creates a virtual display.

(2) create a shell script, setting the virtual display and connecting it.

(3) add the shell script to the Startup Applications, thus having it executed upon each reboot of the machine.

I made one change compared to his overview: I wanted a different resolution for the virtual display, so I used different xrandr parameter values. I found a description on how to find the correct parameter values here: https://ubuntuforums.org/showthread.php?p=8595940

0

I have a easy fix which I stumbled upon. If you have one of those VGA to HDMI or VGA to Display port adapters lying around, you can use it to get past this Monitor or display issue. I used a cheap one $7 adapter and it worked for me. My Ubuntu server is a Lenovo Thinkserver. Hope that helps someone. Especially useful if you are trying to use VNC.

2
  • How and why does such an adapter help with this issue? – Joe Jul 15 '20 at 5:33
  • The resistance in the adpater simulates a VGA load required. Some of the boards with VGA out can detect if a VGA monitor is connected. I ran across an issue with this problem when I was running Ubuntu on a server class machine. I tried several changes to config files on Ubuntu but would not work. As my server was headless, I needed to use VNC on another workstation. I stumbled on the adapter and just tried it out and it worked. Again, did not go to diagnose further. – Durgesh Bhat Kalya Aug 11 '20 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.