1

I'm still in the process of evaluating Unity vs Gnome on Ubuntu 18.04.1

In Unity I noticed that there is no setting for natural scrolling.

In the dconf-editor natural scrolling is set to on.

But it is not scrolling traditionally - how to fix this?

2
2

Linked post explains how to set another property of touchpad, so for clarity I'll write it down here:

# First find number of your touchpad device
xinput list

# then get list of its properties and get number of "Natural Scrolling Enabled"
xinput list-props device_number

# finally set the property to 1 (true)
xinput set-prop device_number prop_number 1
-1

Install Synaptics TouchPad driver for X.Org server:

sudo apt install xserver-xorg-input-synaptics-hwe-18.04

and re-login.

4
  • 1
    Can you explain why this can help? – Pilot6 Dec 20 '20 at 19:49
  • Apparently, because it isn't installed by default and a generic driver is used which does not provide the needed capabilities in the settings? Well, at least it was so in my case. – Andriy Dec 21 '20 at 0:33
  • Both drivers are "generic": libinput an xorg-synaptics. The latter is not specific to any hardware. You are correct that older version of Gnome doesn't have settings for libinput. But it is generally a bad advice, also it can break a system if a HWE stack is not installed. – Pilot6 Dec 21 '20 at 10:36
  • I cannot argue on this, but this method helped me two times already. In both cases after installing xserver-xorg-input-synaptics-hwe-18.04 I could see the configuration settings in Unity for natural scrolling and the touchpad would work much better than with the generic driver. In both cases the HWE stack was installed by default in my systems. – Andriy Dec 22 '20 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.