2

So I can plug either my external lavalier microphone or my headphones directly into my Lenovo T450s laptop's single 3.5mm jack, and they both work using the Built-in Audio = Stereo Analog Duplex setting in pavucontrol:

enter image description here

When I unplug the microphone after having it directly in the jack, the input device port correctly changes to "Built-in microphone" under the Input Devices tab. And it correctly changes back when I plug it back in.

I purchased this microphone and headset combo jack which splits the single 3.5mm jack on my computer into a headset output and a microphone input, but I cannot get the microphone to work through it. The audio out of the splitter works just fine, and the microphone even shows up under pavucontrol when it's plugged into the mic input of the splitter, but it does not seem to register any sound when I use the exact same gnome-alsamixer settings as the ones that worked when the microphone was plugged in directly.

Based on research I've tried adding the following lines to /etc/modprobe.d/alsa-base.conf but neither makes a difference:

options snd-hda-intel model=,dell-headset-multi

and separately,

options snd-hda-intel model=laptop-dmic

Is there anything else I should be looking at? Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.