From time to time I get a lot of static noise when playing sound. It stops when no sound is played (e.g. when music playback is stopped).

  • Seems to be independent from output device (same symptons with either my speakers or headphones)
  • When stopping sound, the static noise lingers for just a tiny bit. It doesn’t stop immediately
  • Unplugging my speakers and then plugging them in again amplifies the symptoms.
  • Opening the alsamixer GUI in the terminal and making sure that the levels are not in the red area makes things a bit better, but doesn’t solve this issue

Lastly, for what I can tell, this happens at completely random times. And it goes away just like that. I tried rebooting several times, no luck. At some point in the future it will be just fine.

So I have absolutely no idea what the hell is going on and how to fix it.


For what it’s worth, running the following seems to fix the issue:

pulseaudio -k

As to why, I have no idea.

Edit: This works reliably for me. Whenever this issue comes up, I run this command to fix it.

| improve this answer | |
  • Works for me as well. Now we need an explanation why! – smirnoffs Aug 27 at 18:48
  • Has no effect for me at all. – Parsa Mousavi Oct 16 at 16:07

I am not a specialist in this area and don't know why the following worked, but it appears to have fixed the exact same problem on my computer.

In the file /etc/pulse/default.pa change the line:

load-module module-udev-detect

to read:

load-module module-udev-detect tsched=0

I found this on another thread where several others also claimed it solved the same audio problem for them.

| improve this answer | |

Not an expert but in my case it was my headphones playing static noise but only when sound was playing.

Turned out it my headphones were over amplified (if that's the correct term). Turning down the headphone output with alsamixer fixed it.

enter image description here

| improve this answer | |
  • do you need to reboot or something for the changes to take effect using this program? – Bersan Oct 6 at 23:06
  • @bersan No, I did not need to reboot. – Cimm Oct 8 at 6:03
  • Simply doesn't work. – Parsa Mousavi Oct 16 at 16:04

I know this question is old but it still seems to be an issue so for those still interested I believe I have a reason for why pulseaudio -k fixes the problem (re @kleinfreund answer and @smirnoffs comment on that answer).

According to the man page for pulseaudio -k is short for --kill and kills the currently running PulseAudio daemon. The system will notice it stopped an start a new instance (hence why the static stops ... until the next time).

I have no idea why the static starts in the first place, maybe a bug or a configuration issue (but that doesn't narrow it down), I'm currently on the hunt for a permanent solution.

| improve this answer | |
  • 1
    ...can you recreate the condition? Did you find it explained elseware? – Thompson Dawes Oct 13 at 13:33
  • I've been seeing the issue frequently, I haven't worked out how to reproduce it consistently yet, just creeps up on me, found this while looking for a permanent solution. Other people across the internet have seen the problem (in fact Arch Linux mentions what I assume is the same issue on their wiki). Though the explanation was just based on the man page my own knowledge. – David Oct 14 at 14:16

I was having the same issue on a dual boot system. Previously pulseaudio -k can temporarily solve the problem once it occurs.

This time it occurs immediately on boot and restarting pulseaudio does not help. Rebooting multiple times into ubuntu does not solve the issue either.

For me, the problem disappear after booting once into windows then boot back to ubuntu...

| improve this answer | |
  • So perhaps a firmware-related problem.Do you use Intel HD audio? – Parsa Mousavi Oct 16 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.