0

After updating to 18.04 my sound settings got all messed up. I'm using an external USB sound card.

pacmd list-sinks:

2 sink(s) available.
  * index: 0
    name: <alsa_output.usb-0d8c_USB_Sound_Device-00.iec958-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE 
    priority: 9048
    volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
            balance 0.00
    base volume: 65536 / 100% / 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 0.00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 0
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0.00 ms; range is 0.50 .. 2000.00 ms
    card: 1 <alsa_card.usb-0d8c_USB_Sound_Device-00>
    module: 8
    properties:
        alsa.resolution_bits = "16"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "USB Audio"
        alsa.id = "USB Audio"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "2"
        alsa.card_name = "USB Sound Device"
        alsa.long_card_name = "USB Sound Device at usb-0000:00:14.0-6.1.4, full speed"
        alsa.driver_name = "snd_usb_audio"
        device.bus_path = "pci-0000:00:14.0-usb-0:6.1.4:1.0"
        sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb3/3-6/3-6.1/3-6.1.4/3-6.1.4:1.0/sound/card2"
        udev.id = "usb-0d8c_USB_Sound_Device-00"
        device.bus = "usb"
        device.vendor.id = "0d8c"
        device.vendor.name = "C-Media Electronics, Inc."
        device.product.id = "0102"
        device.product.name = "CM106 Like Sound Device"
        device.serial = "0d8c_USB_Sound_Device"
        device.string = "iec958:2"
        device.buffering.buffer_size = "352800"
        device.buffering.fragment_size = "176400"
        device.access_mode = "mmap+timer"
        device.profile.name = "iec958-stereo"
        device.profile.description = "Digital Stereo (IEC958)"
        device.description = "CM106 Like Sound Device Digital Stereo (IEC958)"
        alsa.mixer_name = "USB Mixer"
        alsa.components = "USB0d8c:0102"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-usb"
    ports:
        iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
            properties:

    active port: <iec958-stereo-output>
    index: 1
    name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
    driver: <module-alsa-card.c>
    flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
    state: SUSPENDED
    suspend cause: IDLE 
    priority: 9039
    volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
            balance 0.00
    base volume: 65536 / 100% / 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 0.00 ms
    max request: 0 KiB
    max rewind: 0 KiB
    monitor source: 2
    sample spec: s32le 2ch 44100Hz
    channel map: front-left,front-right
                 Stereo
    used by: 0
    linked by: 0
    configured latency: 0.00 ms; range is 0.50 .. 185.76 ms
    card: 2 <alsa_card.pci-0000_00_1b.0>
    module: 9
    properties:
        alsa.resolution_bits = "32"
        device.api = "alsa"
        device.class = "sound"
        alsa.class = "generic"
        alsa.subclass = "generic-mix"
        alsa.name = "ALC3232 Analog"
        alsa.id = "ALC3232 Analog"
        alsa.subdevice = "0"
        alsa.subdevice_name = "subdevice #0"
        alsa.device = "0"
        alsa.card = "1"
        alsa.card_name = "HDA Intel PCH"
        alsa.long_card_name = "HDA Intel PCH at 0xf2634000 irq 30"
        alsa.driver_name = "snd_hda_intel"
        device.bus_path = "pci-0000:00:1b.0"
        sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
        device.bus = "pci"
        device.vendor.id = "8086"
        device.vendor.name = "Intel Corporation"
        device.product.id = "8c20"
        device.product.name = "8 Series/C220 Series Chipset High Definition Audio Controller"
        device.form_factor = "internal"
        device.string = "front:1"
        device.buffering.buffer_size = "65536"
        device.buffering.fragment_size = "32768"
        device.access_mode = "mmap+timer"
        device.profile.name = "analog-stereo"
        device.profile.description = "Analog Stereo"
        device.description = "Built-in Audio Analog Stereo"
        alsa.mixer_name = "Realtek ALC3232"
        alsa.components = "HDA:10ec0292,17aa2210,00100001"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
    ports:
        analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
            properties:
                device.icon_name = "audio-speakers"
        analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
            properties:
                device.icon_name = "audio-headphones"
    active port: <analog-output-speaker>

Obviously the goal is to use the USB device as the main output. I have no idea why it's "suspended" or "idle". Also, the speaker testing app in the Settings section ("Front Left", "Front Right") doesn't bring up any test sounds.

1

'Suspended' and 'Idle' is usual if no sound playing

USB device is set for Digital audio playback (spdif)

Realtek ALC3232 is set for Analog Stereo Playback

I suspect you probably want to change USB device to Analog Playback same as other device?

If so, got to pavucontrol --tab 5 (Pulseaudio Volume Control Configuration tab)

First device listed will be card 0 (USB)

Use drop-down menu to change profile to 'Analog Stereo Playback'

| improve this answer | |
  • Thanks. I had to install pavucontrol (for some reason I didn't have it). Thanks to the command you proposed I'm able now to configure most of the stuff I want. There's just one thing: there are two outputs, an analog one and a digital one. I'm setting the digital one as the "fallback" one (as in "default", I'm guessing?). However, after a reboot they switch around again. The only way I was able to set it straight was to disable the analog output totally and this setting has been eventually remembered by the app. Is there a smoother way around it? – kubakonrad Aug 19 '18 at 8:43
  • fallback is not default – nik gnomic Aug 20 '18 at 18:13
  • does "disable analog output totally" relate to USB device? when you said "USB device as the main output" i was thinking both devices in use as you didn't say only output – nik gnomic Aug 20 '18 at 20:41
  • I have no idea what you mean by "smoother way around it" It seems like the audio settings for your DE are using may not be saving Pulseaudio settings (as it appears turning off one device cause the other to work without settings changed) – nik gnomic Aug 20 '18 at 20:44
  • I had previously fixed it with pactl, but this is way way easier. Thank you ! – 3nrique0 Mar 1 '19 at 13:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.