2

I have been trying to install MyOpenLab on ubuntu 18.04. It is freeware alternative to LabView. I found that it required java to run so I installed the java through the terminal. Now when I try to open MyOpenLab through the terminal, I am greeted with the following message.

Error adn warnings

Can someone please help me with my installation. Thanks.

EDIT: I downloaded the software MyOpenLab from the website myopenlab.org. It was downloaded to my Downloads folder. I then extracted it in the same directory.

I then right-clicked the file and set permissions to read and write and then selected the option "Allow executing file as program."

After that, I opened a terminal in the same directory and entered the command "./start_linux".

The program name then appeared and it asked me about the license agreement. I gave proceed and then it asked me for the path for user defined elements. After selecting the path and clicking on next, I was greeted with the errors and warning.

Terminal command

MyOpenLab directory

Also the version of my java are as follows. I obtained them with the command "java --version" at the terminal:

java version "10.0.2" 2018-07-17
Java(TM) SE Runtime Environment 18.3 (build 10.0.2+13)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10.0.2+13, mixed mode)

Please help me out with the installation process as it is very important.

  • 2
    Please add some background information - where do you/we can get this software? What actions did you perform? What Java version do you have (add output of update-java-alternatives -l)? Add all info to the question. – N0rbert Aug 18 '18 at 10:58
  • Hi I have added the necessary information. Kindly help me out. – Soumya Sambeet Mohapatra Aug 18 '18 at 11:52
2

On my Ubuntu 18.04.1 LTS I did the following:

cd ~/Downloads
wget https://myopenlab.org/distribution_linux_3.11.0.zip
unzip distribution_linux_3.11.0.zip -d distribution_linux_3.11.0
cd distribution_linux_3.11.0
sh ./start_linux

and got the same error as you have.

Then I installed OpenJDK 8

sudo apt-get install openjdk-8-jre

and set it as default system VM:

sudo update-java-alternatives --set \
java-1.8.0-openjdk-$(dpkg --print-architecture)

then tried to launch it again:

sh start_linux

and MyOpenLab launches normally

MyOpenLab on Ubuntu 18.04 LTS

Notes:
1. I have never used this software. Just wanted to help you. Thank you for your finding!
2. On Ubuntu 16.04 LTS Xenial Xerus it runs without any special actions (as it uses openjdk-8 by default) .

0

As N0rbert wrote, you can see that MyOpenLab depends (as of this date) on Java 1.8.

Assume you want to keep your newer version of openjdk and still be able to run MyOpenLab.

  1. Check which openjdk you have in your system:

    sudo update-java-alternatives -l
    

    That is from the package java-common. I am using Debian. In my case, this is the output:

    java-1.11.0-openjdk-amd64  1111  /usr/lib/jvm/java-1.11.0-openjdk-amd64
    java-1.8.0-openjdk-amd64  1081  /usr/lib/jvm/java-1.8.0-openjdk-amd64
    

    If you don't have openjdk1.8, then install it, you need it for MyOpenLab.

  2. You want your system to be up-to-date. So make openjdk1.11 default:

    sudo update-java-alternatives --set java-1.11.0-openjdk-amd64
    
  3. Check just to make sure, your java --version

    In my case: openjdk 11.0.1 2018-10-16

  4. In your MyOpenLab directory, in my case /opt/programs/MyOpenLab/

    you find the file: start_linux Edit this file. Change the line saying:

    java -splash:splash.png -jar myopenlab.jar Elements
    

    change it to:

    /usr/lib/jvm/java-1.8.0-openjdk-amd64/bin/java -splash:splash.png -jar myopenlab.jar Elements
    

The address to your openjdk1.8 is from step 1:

sudo update-java-alternatives -l

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.