5

I am connecting an external device via ethernet. In network manager, it shows the wired connection as "Connecting". I am able to ping and SSH to the remote device during this phase, the connection works fine.

After a period of time (~30s?) I get a message "Activation of network connection failed" and the wired connection is disabled. I have to re-enable it (or unplug/plug in the cable) to continue working.

Potentially relevant information:

  • I have a stable wifi connection to the internet, but the problem also repros when I disable it.
  • The remote device does not have internet connectivity.
  • The remote device is ipv6 only.
  • I'm running a Dell XPS13 and using a USB-C to ethernet adapter.
  • I have observed the behaviour on duplicates of all external hardware (cables, devices).
  • A co-worker is using archlinux and doesn't have this problem.

Logs:

# Excerpt from: journalctl -u NetworkManager
Aug 17 17:59:47 yoshi NetworkManager[1043]: <info>  [1534553987.5996] device (enx00e04c00072b): Activation: starting connection 'Wired connection 1' (74876abf-ba83-38b1-813d-1fa271132731)
Aug 17 17:59:47 yoshi NetworkManager[1043]: <info>  [1534553987.6002] device (enx00e04c00072b): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Aug 17 17:59:47 yoshi NetworkManager[1043]: <info>  [1534553987.6012] device (enx00e04c00072b): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Aug 17 17:59:47 yoshi NetworkManager[1043]: <info>  [1534553987.6026] device (enx00e04c00072b): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
Aug 17 18:00:19 yoshi NetworkManager[1043]: <info>  [1534554019.5847] device (enx00e04c00072b): state change: ip-config -> failed (reason 'ip-config-unavailable', sys-iface-state: 'managed')
Aug 17 18:00:19 yoshi NetworkManager[1043]: <warn>  [1534554019.5858] device (enx00e04c00072b): Activation: failed for connection 'Wired connection 1'
Aug 17 18:00:19 yoshi NetworkManager[1043]: <info>  [1534554019.5870] device (enx00e04c00072b): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')

Questions:

  1. What is Ubuntu using to determine that this connection failed, given that ping/ssh work fine?
  2. How can I fix it?

Update: I changed the settings for the connection so that IPv4 was disabled and IPv6 was Link-Local Only (from "Automatic"). This appears to have fixed the issue, but I don't really understand what I've done so an answer with more details (and confirmation that this is a legitimate fix) would be appreciated.

  • Look at the logs. journalctl $(type -p NetworkManager) will help you with Step 1. Step 2 is 100% dependent on step 1. – waltinator Aug 18 '18 at 2:15
  • Thank you. Your exact command didn't work ("Invalid Argument") but led me to the right place. I have added logs to the question, it appears to be something to do with IP management? – Xavier Shay Aug 18 '18 at 21:55
  • Please see my answer. Please remember to accept it if it was helpful. Thanks! – heynnema Oct 11 '18 at 15:09
3
+50

IP addresses don't appear automagically: they need a DHCP server to work reliably under all circumstances.

The IPV6 protocol allows for SLAAC to assign a temporary IP address, but the real solution is to install a DHCP server on your machine and your colleague running Arch probably has one running.

As to your questions: 1 and 2 are interconnected "Link-Local only" forces SLAAC to be used and to bypass the DHCP server even if there would be one.

| improve this answer | |
  • But I have an IP address, otherwise I wouldn't be able to SSH into the other machine. I think what's going on is that NetworkManager doesn't consider a link-local IP to be "good enough" when establishing a connection in automatic mode. I believe SLAAC is what I have been using - "ping and SSH", the ping was to discover the remote IP address. – Xavier Shay Aug 25 '18 at 21:57
  • So? Have you tried setting up a DHCP server? @XavierShay – Fabby Aug 25 '18 at 22:08
  • No, I don't need one since (per update) link-local works fine. I think the answer to my question is "link local IP address isn't the same as a real IP address, at least as far as the network manager is concerned, and that's literally the definition of what "automatic" is - looking for a non-linklocal IP" – Xavier Shay Aug 27 '18 at 2:04
  • Sorry for being confusing. Edited. – Fabby Aug 27 '18 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.