0

I upgraded through the Software prompt from 16.04 LTS to 18.04 LTS. Everything went well until near the end when there were a bunch of lib* failures. It said the update failed and the system could be unstable. Sure enough it upgraded to 18.04 but had a login loop. I managed to solve that somehow (I've been using the xorg driver with no Nvidia drivers installed anyway). Now it won't boot on kernel 4.15 at all. It does work on 4.13 and some earlier ones but it is not functioning properly. My LAMP server has not restarted. My wireless USB is worked at first but now is staying green no matter what so I'm using a LAN. I've tried updating, upgrading but there is nothing to do. I've tried the suggested DIST upgrade from other posts - nothing. Is there anything to do to make it stable or is a clean install the only real fix? P.S. I've never had a successful upgrade with Ubuntu and I'm a long-time user. I always wind up with a new install it seems. I've got a an HP Pavilion. 2GB AMD Athlon 64x2 64 bit.

  • Try booting into kernel 4.13 and then run sudo apt full-upgrade then to boot – George Udosen Aug 18 '18 at 1:26
  • I'm a long-time user and I've always had successful release upgrades. Perhaps you are doing something different than I do. – user535733 Aug 18 '18 at 3:19
  • Thanks for the help. Unfortunately it says I have 0 to upgrade, remove, etc. I've never had success with upgrading as much as I've tried over the years. I had a Dell Dimension 4700 originally then moved the the HP. It will let me boot to 4.15.0.24 but I get odd behavior. Like my Terminal won't open when I click Open Terminal from the desktop. My Chrome Remote Desktop is online but when I try to connect it tells me the computer is refusing connections. My Owncloud and the associated LAMP server do not seem to be working. I can't get to my .ddns.net website which I use for Owncloud. – Darris J. Brock Aug 18 '18 at 3:57
  • Upon reboot I may get a login loop, which I can solve by redoing the selection of lightdm as the default manager. But now I'm getting a 640x480 display all the time. – Darris J. Brock Aug 18 '18 at 4:50
0

I was unable to resolve this so I attempted a fresh install of 18.04. On multiple attempts it gave me a failure to install grub on /sda and I was never able to get the grub to install anywhere. So I reinstalled 16.04, updated at the terminal using sudo update-manager -c

It updated to the latest kernel, restarted, and then I did it again to get the 18.04 upgrade.

This finished successfully. My Belkin wireless USB works. Now I will begin restoring my files and installing the LAMP server to get my site back on line. This has taken be all day and all evening of a Saturday. There's no excuse for this. If it is going to give me a host of failures at the end, why can't it check before it installs to prevent it from installing? Thanks for all who attempted to help.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.