13

As in this question, I found that when I set "Settings -> Dock -> Auto-hide the Dock" to "On", the dock almost completely covers the leftmost column of desktop icons:

enter image description here

This makes it very difficult to see or select those icons. (I can manually drag them out from under the dock, but then e.g. clicking "arrange icons by name" or changing the dock auto-hide settings moves them back under it again.)

Unlike the OP for the linked question, whose preferred solution is to hide the dock when there are no windows covering it, I would prefer the icons to default to locations that are not covered by the dock, as they do when the dock is not set to auto-hide. Is there any way to do this?

  • Secondary question and mini-rant: why on earth didn't this bug get caught before release? There are only three dock customization options enabled in the default settings GUI, and one of them is completely broken! Isn't the main motivation for allowing the dock to be auto-hidden so that people can use that desktop real estate? – tparker Aug 17 '18 at 22:34
4
+50

The current answer is you can't. This is a known bug since 17.10, https://bugs.launchpad.net/ubuntu/+source/gnome-shell-extension-ubuntu-dock/+bug/1723117

So didn't really fall thru the cracks, there isn't atm anyone assigned to fix as the most important thing about the Desktop version of Ubuntu currently is to limit the amount of resources used on it. (i.e money

  • In my opinion, this is actually a pretty serious bug - it completely breaks the "auto-hide the dock" option, which is a pretty important one. It's not quite as bad if you turn off intellihide as in the answer to the linked question, but still pretty bad. – tparker Sep 14 '18 at 22:15
0

I wouldn't say this is because of Canonical removing resources from the desktop, as another answer states. After all, the dash-to-dock extension is independently developed and used in other distributions too (for example, Manjaro).

Apparently, the issue cannot be solved at the extension level (https://github.com/micheleg/dash-to-dock/issues/17). So it's not that easy to fix without upstream changes, and upstream they already decided against desktop icons, so...

OTOH, probably intellihide (the current behavior) is better than autohide for Ubuntu, even with the bug. IMO, Ubuntu should remove the desktop icon extension for good, at some point.

I would say: just move your dock to the bottom or the right (so it's not true that the bug completely breaks the intellihide feature, as some comment states).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.