2

I buy the TP Link T2U AC600 wireless adaptor because they 'have' linux driver, but i try to install it and until now nothing. My machine have a Ubuntu 18.04 and the oficial drive work until kernel 3.16. The information about my machine:
lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 1532:0110 Razer USA, Ltd 
Bus 001 Device 011: ID 148f:761a Ralink Technology, Corp. 
Bus 001 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 001 Device 015: ID 22b8:2e25 Motorola PCS 
Bus 001 Device 006: ID 1ea7:0011  
Bus 001 Device 008: ID 0951:16a1 Kingston Technology 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

uname -a

Linux lowe 4.15.0-32-generic #35-Ubuntu SMP Fri Aug 10 17:58:07 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

I try all this bellow and nothing works. Attention the last command is where the error appears:

  1. mt7610u_wifi_sta_v3002_dpo_20130916, get a error on make command:

git clone https://github.com/chenhaiq/mt7610u_wifi_sta_v3002_dpo_20130916.git
cd mt7610u_wifi_sta_v3002_dpo_20130916
make

scripts/Makefile.build:332: recipe for target '/mnt/downloads/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux/../../os/linux/rt_profile.o' failed
make[2]: *** [/mnt/downloads/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux/../../os/linux/rt_profile.o] Error 1
Makefile:1552: recipe for target '_module_/mnt/downloads/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux' failed
make[1]: *** [_module_/mnt/downloads/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.15.0-32-generic'
Makefile:403: recipe for target 'LINUX' failed
make: *** [LINUX] Error 2
  1. archer-t2u-ubuntu-installer , work for ubuntu 17.10. I try to install on ubuntu 18.04 and get a error on python3 t2u-driver-installer.py

git clone --branch 2.0.0 git@github.com:ivannieto/archer-t2u-ubuntu-installer.git
cd archer-t2u-ubuntu-installer/ && python3 t2u-driver-installer.py

cc1: some warnings being treated as errors
scripts/Makefile.build:332: recipe for target '/mnt/downloads/archer-t2u-ubuntu-installer/driver-files/os/linux/../../os/linux/rt_linux.o' failed    
make[2]: *** [/mnt/downloads/archer-t2u-ubuntu-installer/driver-files/os/linux/../../os/linux/rt_linux.o] Error 1
Makefile:1552: recipe for target '_module_/mnt/downloads/archer-t2u-ubuntu-installer/driver-files/os/linux' failed
make[1]: *** [_module_/mnt/downloads/archer-t2u-ubuntu-installer/driver-files/os/linux] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.15.0-32-generic'
Makefile:393: recipe for target 'LINUX' failed
make: *** [LINUX] Error 2
insmod: ERROR: could not load module mt7650u_sta.ko: No such file or directory
*************************

Your computer should be restarted now.
Please close all running programs and restart manually when you're done.
An executable will be installed to enable or disable the adapter.
Just run in your terminal '$ sudo t2u-driver'.
  1. TP-link TL-WN725N driver for 18.04 version, that is not the correct version for adapter but i try:

git clone https://github.com/lwfinger/rtl8188eu
cd rtl8188eu
make all
sudo make install
sudo insmod 8188eu.ko

insmod: ERROR: could not insert module 8188eu.ko: Required key not available  
  1. Installing Tp-Link AC600 on Ubuntu 16.04.1 x64 [duplicate], this is the most popular thread about the adapter, but not work too, And yes, i install dmks and build essential.

git clone https://github.com/Myria-de/mt7610u_wifi_sta_v3002_dpo_20130916.git
cd mt7610u_wifi_sta_v3002_dpo_20130916
make

scripts/Makefile.build:332: recipe for target '/mnt/downloads/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux/../../os/linux/rt_profile.o' failed
make[2]: *** [/mnt/downloads/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux/../../os/linux/rt_profile.o] Error 1
Makefile:1552: recipe for target '_module_/mnt/downloads/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux' failed
make[1]: *** [_module_/mnt/downloads/mt7610u_wifi_sta_v3002_dpo_20130916/os/linux] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.15.0-32-generic'
Makefile:403: recipe for target 'LINUX' failed
make: *** [LINUX] Error 2  
  1. try to install tp-link wireless adapter (Ubuntu 16.04), that PPA repository does not work on Ubuntu 18.04 and break the apt update.

  2. Hygens/mt7610u_ubuntu_1610, but just work for 16.04

git clone https://github.com/Hygens/mt7610u_ubuntu_1610.git
cd mt7610u_ubuntu_1610/
make

In function ‘memcpy’, inlined from ‘rt_ioctl_iwaplist’ at /mnt/downloads/mt7610u_ubuntu_1610/os/linux/../../os/linux/sta_ioctl.c:696:2: ./include/linux/string.h:340:4: error: call to ‘__read_overflow2’ declared with attribute error: detected read beyond size of object passed as 2nd parameter __read_overflow2();
scripts/Makefile.build:332: recipe for target '/mnt/downloads/mt7610u_ubuntu_1610/os/linux/../../os/linux/sta_ioctl.o' failed
make[2]: *** [/mnt/downloads/mt7610u_ubuntu_1610/os/linux/../../os/linux/sta_ioctl.o] Error 1
Makefile:1552: recipe for target '_module_/mnt/downloads/mt7610u_ubuntu_1610/os/linux' failed
make[1]: *** [_module_/mnt/downloads/mt7610u_ubuntu_1610/os/linux] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.15.0-32-generic'
Makefile:405: recipe for target 'LINUX' failed
make: *** [LINUX] Error 2  

I search more others solutions but i have the limit of 8 links.
Thank you for help!

8
  • did you run sudo t2u-driver – Joshua Besneatte Aug 17 '18 at 20:40
  • is this really a dupe? the answer at the other question is "get different hardware" is that really the solution???? – Joshua Besneatte Aug 17 '18 at 20:45
  • @JoshuaBesneatte, I try to run sudo t2u-driver but the system does not find the adapter. – Diego Corrêa Aug 17 '18 at 21:17
  • did you try using that ppa in my answer? if that doesn't work, let me know – Joshua Besneatte Aug 17 '18 at 21:21
  • @JoshuaBesneatte The answer in the dupe is actually, “No, you cannot compile any driver for this device in any modern kernel version and so I recommend that you get a different device.” – chili555 Aug 17 '18 at 23:06