2

UsbHub not working on Ubuntu 18.04 LTS.

I have a notebook with only one USB 3.0 and two USB Type-C.

I tried to insert usb hub(guess usb hub 2.0) in USB 3.0 slot, but Ubuntu not recognized it. Also i tried to insert Logitech k330 keyboard - same result. But usb-flash that use USB 3.0 perfectly works on this slot.

dmesg result:

[ 411.156178] usb 1-7: new full-speed USB device number 12 using xhci_hcd
[ 411.284575] usb 1-7: device descriptor read/64, error -71
[ 411.521344] usb 1-7: device descriptor read/64, error -71
[ 411.629659] usb usb1-port7: unable to enumerate USB device

I tried:

sudo vi /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 usbcore.old_scheme_first=1"

Am i missed something?

Edit 1

I don't think that the problem in hub, because on Windows 10 this hub works perfectly and Wireless Keyboard too. I hope the problem in configuration. And i have Lenovo yoga with very ugly BIOS configuration. There are no buttons in BIOS to change USB settings.

Unfortunately i haven't powered usb 2.0 hub. But i have USB 3.0 hub. Today i tried to use USB 3.0 hub. It's Qilive USB 3.0 hub with 7 out USB 3.0 ports. This hub was successfully connected, but only 4 USB 3.0 ports was recognised:

[ 4694.376640] usb 1-7.4: new high-speed USB device number 16 using xhci_hcd
[ 4694.401994] usb 1-7.4: New USB device found, idVendor=05e3, idProduct=0610
[ 4694.402000] usb 1-7.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 4694.402005] usb 1-7.4: Product: USB2.0 Hub [ 4694.402009] usb 1-7.4: Manufacturer: GenesysLogic
[ 4694.403092] hub 1-7.4:1.0: USB hub found
[ 4694.403535] hub 1-7.4:1.0: 4 ports

It's something like power issue, but why usb 2.0 devices not working if connected to USB 3.0 still unknown... And why on Windows there are no USB 3.0 or USB 2.0 issues.

Edit 2

Tried to connect USB mouse directly via USB 3.0 slot.

mouse[USB2.0]<->notebook[USB3.0]

It didn't connect. But when i tried to connect USB mouse via USB 3.0 hub, It connects perfectly.

mouse[USB2.0]<->[USB3.0]hub[USB3.0]<->notebook[USB3.0]

Something like I can not plug USB 2.0 devices in USB 3.0 slot directly in Ubuntu... But if i connect USB 3.0 hub, and connect USB 2.0 device to this hub - everything works... Will be glad any help.

  • sometimes this error could be because the hub is not getting adequate power. have you tried with a powered hub? – Joshua Besneatte Aug 17 '18 at 17:45
  • also have you tried fiddling with your USB setting in your BIOS? – Joshua Besneatte Aug 17 '18 at 17:51
0

I've had this problem on other distros like Linux Mint. They sometimes get out of sync with the central repository. Personally I think it is how firmware is managed and it's quite possible that the drivers you have for your hub are out of date with current Ubuntu firmware. If you're using an older machine don't bother trying to 'update firmware' cos you may brick your machine if you're unfamiliar with that. What you can do to confirm the problem is run

sudo hwls |more

to see if the usb-driver is loaded or use the modprobe -l utility.

If you don't see it in any of these listings then the firmware is not recognizing it and has blocked it. I think this has to do with new security features built into Ubuntu to lock down USB ports like secure mode. You may have to update how your boot-strap works by managing your uEFI bootstrap better with SHIM/MKO. See this site for help in fixing bootstrap. It describes how secure mode works and suggests other tools on how to manage / sign a USB driver.

If you have disabled secure mode in BIOS then most likely the new firmware (ucode) has locked out your hub. I often hit this bug after doing a distro update. If you did this recently or update-grub then you most likely got something out of sync. Distro upgrade utilities can run into problems and leave the system in a mess, and that's why some users avoid them then go for a fresh install. There are better tools out there for managing usb-utilities which Rod Smith describes in his book. Be sure to donate to his publication!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.