0

The main problem is the 'No wi-Fi Adapter Found.'

I've read several threads concerning this problem, and tried to follow the leads of some of them. Thus, I searched for my network adapter, which is found to be MT7630E, I downloaded the driver release folder for it from another laptop. Then I attempted to install it throught the terminal, but then when I used the command sudo ./install.”, it replied back with ‘./install: line 10: make: command not found’.

So, I searched more then I found that perhaps I need to install Linux Headers for that command to work, so again I downloaded that from another laptop. It was a .deb file so when I tried to install it using Ubuntu Software, it didn’t work (when I clicked for install, it asked me for the password, which I wrote down but it never installed it).

The thing is most of the solutions require writing something in the terminal that requires internet on the laptop, and since WiFi is not working, and I don't have a cable opening in my laptop, I can't use these solutions, I can only download something from another laptop, and install it on mine. What should I do now?

Update: I followed the instructions for Keryx and Cube for offline downloaded packages, and the two options didn’t work out. Keryx never managed to make the list of the packages on my offline laptop in the first place, and Cube doesn’t want to install most of them after they were downloded on the online laptop.

  • 1
  • I recommend Pilot6’s answer because it will reinstall the driver via DKMS for each kernel update. If that doesn't help, could you please add a little more detail? What exactly did you do, what did you expect to happen and what happened instead? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. Please edit your post to add information instead of posting a comment. (see How do I ask a good question?) – David Foerster Aug 17 '18 at 12:32
  • Hello David, first I can’t really put the messages in their entirety because my Ubuntu laptop is not connected on the internet, so I try to rewrite them here. Also, Pilot6 answer doesn’t work in my case for the same reason, my laptop is entirely unconnected to the internet. And, okay, I’ll try to clarify my question more. Thank you. – Pavly Nazieh Aug 17 '18 at 13:18
  • 1
    Possible duplicate of How can I install software or packages without Internet (offline)? – karel Aug 17 '18 at 13:43
  • 1
    In that case please set up a temporary internet connection for the computer in question (e. g. through a wired Ethernet connection) or use a portable storage medium to transfer the required packages as well as the source code from a computer with internet connection. – David Foerster Aug 17 '18 at 22:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.