1

I tried to install the below package :

sudo apt-get install python-pygraphviz python-kiwi python-pygoocanvas libgoocanvas-dev ipython

and it's alarmed :

E: Unable to locate package python python-pygoocanvas
E: Unable to lovate package libgoocanvas-dev

Note : on Ubuntu 18.04

8

1 Answer 1

3
  1. Open your browser

  2. Navigate to https://www.nsnam.org/wiki/Installation

  3. Click on 2.1.2 Ubuntu/Debian/Mint

  4. Then read the docs

    ...

    For Ubuntu 18.04 and later, python-pygoocanvas is no longer provided. The ns-3.29 release and later upgrades the support to GTK+ version 3, and requires these packages:

    apt install gir1.2-goocanvas-2.0 python3-gi python3-gi-cairo python3-pygraphviz gir1.2-gtk-3.0 ipython3    
    

    ...

  5. And follow it line by line.

Note: I have never compiled this thing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .