1

I have upgraded to Ubuntu 18.04.1 LTS, and I am having issues with the Epson Printer Utility. I installed it using the epson-printer-utility_1.0.2-1lsb3.2_amd64.deb package from their website, after installing lsb as they recommend. The program starts properly, but it does not find the printer (I use the printer via network).

The odd thing is that I can print and scan with the printer, everything is working ok, I just have issues with the epson-printer-utility.

ImageScan also did not find the scanner at first, but I could resolve the issue by editing the imagescan config file in /etc/imagescan/ and specifying the scanner IP address... I have looked for a similar configuration file for the epson printer utility, but I could not find anything.

The only file I found that may be close to a config file was the 79-udev-epson.rules, in opt/epson-printer-utility and it currently looks like this:

#chmod device EPSON group
#ACTION=="add", ATTRS{manufacturer}=="EPSON", DRIVERS=="usb", SUBSYSTEMS=="usb", ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="*", MODE="0666"
ATTRS{manufacturer}=="EPSON", DRIVERS=="usb", SUBSYSTEMS=="usb", ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="*", MODE="0777"

I do not see a way to specify an IP address in this file.

Also, when I did the set up for my scanner and ran sane-find-scanner, I got different vendor and product ids: 0x138a and 0x0017, I do not know if they should be the same for the printer.

I tried to change the product and vendor ids to 0x138a and 0x0017, it did not work. I tried to uncomment the ADD line, it did not work... I also tried to add the following line:

ATTRS{idVendor}=="0x138a", ATTRS{idProduct}=="0x0017", MODE="0666", GROUP="printer", ENV{libsane_matched}="yes"

But no luck so far...

Any help will be greatly appreciated! Thanks a lot in advance.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.