0

I am setting up a laptop for someone. It has 2GB memory (and a swap partition in case it helps) which boots very slowly. This list shows all the processes which take over ten seconds from system-analyze blame:

1min 30.200s nmbd.service
     52.468s apt-daily.service
     32.414s plymouth-start.service
     31.853s plymouth-quit-wait.service
     31.848s lightdm.service
     26.335s plymouth-read-write.service
     14.025s dev-sda1.device
     12.957s ufw.service
     11.176s systemd-journal-flush.service

I've been advise by the Ubuntu Budgie people that I can:

  1. Remove nmbd.service as there is no intention to connect to Windows computers. How would I do this?
  2. Fix the way apt-daily.service starts - this shouldn't be happening until later anyway. A couple of ways to do this are discussed here Ubuntu 16.04 slow boot (apt-daily.service). One suggestion times out the initial attempt to start the service and the other postpones it till long after boot has finished. Would either be satisfactory?
  • systemctl disable nmbd.service for the service file (I think as I don't know what nmbd.service is) and just try one of the solutions given and see if it works. if not try the other. if that doesn't help then come and ask for help – j-money Aug 16 '18 at 0:34
  • Thanks, will try that command. It's samba which allows connection to Windows machines - which I don't intend. – ChrisOfBristol Aug 16 '18 at 1:14
  • ..and will try whichever of the two is simplest for apt-daily.service. – ChrisOfBristol Aug 16 '18 at 1:25
0

You can disable the nmbd service, though you could also just uninstall samba. It would also help to know how long 'very slowly' is as this is very relative. Apart from that - as far as I know most of these services start independently, so even though nmbd takes a long time, it doesn't stop other services.

edit: Other items that you could try to disable/stop: graphical boot screen (plymouth) or ufw (firewall likely not enabled by default anyway)

I think the bigger problem is probably that the laptop is relatively slow in general, with only 2 GB RAM and likely (I suspect) only a slow hdd and not a faster one or an ssd. So a more permanent solution would be to try to get a cheap ssd, this will increase your startup time much more than trying to kill a process here or there.

  • On previous OS (either 18.04 or 17.10, I can't remember) timings were 1:40/1:15 it's now 3:30/1:30. Times are from switch on to password entry and password entry to ready. I suppose it carries on in the background anyway so only the totals matter: 2:55 and 5:00. It's satisfactory once going. – ChrisOfBristol Aug 16 '18 at 1:18
  • You could try disabling ufw (firewall) as I think by default it is not active anyway. (it might have changed though) You could also disable plymouth or remove it (graphical splash screen) wiki.ubuntu.com/Plymouth Maybe new drivers in kernel or xorg slow it down on your config. – step21 Aug 16 '18 at 1:25
0

Stopping neither made any difference, presumably they weren’t holding anything else up. I tried Standard Ubuntu in desperation - same problem. What fixed it was this: Boot very slow because of drm_kms_helper errors

This is a bug. To avoid delay you can use workaround. From terminal run:

    sudo nano /etc/default/grub

Then add the kernel boot parameter: video=SVIDEO-1:d , so it will look like this: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"

    sudo update-grub
    sudo reboot

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.