I have a toshiba l655d-s5145. There is no physical toggle for the wireless, although the f8 key is supposed to do the trick. It doesn't. The wireless has been working since October, and suddenly, nothing. RFKILL reports that the wireless is hard blocked, but unblock wifi, unblock 0, unblock all do nothing. I inserted a usb dongle, and that is also disabled by hardware switch, although rfkill reports that it is neither hard nor soft blocked. My onboard wireless is

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE
802.11b/g/n WiFi Adapter (rev 01)

according to lspci. Lsmod reports that these drivers are loaded.

rtl8192c_common        75767  1 rtl8192ce rtlwifi               110972 1 rtl8192ce

I resorted to reformatting the drive and reinstalling, but that also did not work. In BIOS I restored system defaults as there is no specific entry for wifi. Before reinstalling a pure xubuntu I went into Unity and saw that the airplane mode was on and despite being toggled off, it returned to the on position. I'm not sure where to find airplane mode in Xubuntu. What else can I do? I need my wireless.


I found the answer in a thread over at ubuntuforums. I had to remove the battery and disconnect the charger, press the power button for at least thirty seconds, put it all back together and boot into bios. From there I had to restore system defaults, save changes, and presto, wireless is working again. I gather that this is a fix specific to toshiba laptops without a physical wireless.

  • This fix also works on Acer Travelmate 2450
| improve this answer | |
  • cwwk, it appears it's not a toshiba specific issue because my acer aspire one also had the same problem and I used the same fix. Worked like a charm. And it has a physical switch. – Thiago Zanetti Mar 2 '12 at 19:46
  • Just what I needed to fix my issue – CodeLikeBeaker Apr 1 '12 at 0:19
  • doesn't work for me – Ian Turton Jun 19 '13 at 18:37
  • 4 years passed and this still worked on a satellite L755 with the same symptom. Big thx Jorge and if anyone have some explanation on how this works, it would be welcome. – gdupont Jan 8 '16 at 23:34

If a USB wireless is hard blocked as well then it means it is definitely a hardware issue. Enter your BIOS settings and turn action keys on, then try disabling or enabling the wireless. When you enable action keys, you won't have to hold down the function key, so press F8 instead of function f8.

| improve this answer | |
  • Thanks for responding. The usb wireless is not blocked, but still reads disabled by hardware switch. Results for rfkill list 0: phy0: Wireless LAN Soft blocked: no Hard blocked: yes 1: phy1: Wireless LAN Soft blocked: no Hard blocked: no I've been all over my bios and haven't seen an entry for action keys, is there a specific menu where it is usually located? I'll check now and report back. – cwwk Feb 22 '12 at 17:39
  • Nope, BIOSes are all unique. No standard place. Is there a wireless light on your laptop? – William Feb 22 '12 at 17:45
  • Couldn't find anything related to action keys. There is a wireless light, but it is not on. – cwwk Feb 22 '12 at 17:46
  • Well, if USB wireless adapters are blocked, this means the wireless switch on your laptop is off. Can you try not holding down the function key and pressing the button What model laptop is it? – William Feb 22 '12 at 17:49
  • I have a toshiba satellite l655d-s5145. I tried holding down the fn+f8. Nothing. I tried holding down super+f8 as well as ctrl...etc. Nothing. I googled the model number to see if there was a switch somewhere that I couldn't find, and no luck. – cwwk Feb 22 '12 at 17:55

I had a similar problem. But a little bit more confusing. I dropped my lenovo laptop one day and my hardware switch together with my built-in wifi adaptor just broke. I bought USB WiFi adaptor and tried to reinstall drivers, but no luck. Then I just went to BIOS and set "WLAN control" to disable and now everything works as a charm.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.