0

Similar to this question How do I disable the blinking cursor in gnome-terminal?

I want my gnome-terminal instances to always display. For some reason when I follow the above questions steps it does display solidly but when I move the terminal cursor with an arrow key it no longer displays. I want it to always display solid. In Ubuntu 16.04.

Thanks!

EDIT: Requested screenshot of terminal preferences enter image description here enter image description here

  • The linked question is dated 2011, most of the answers there no longer apply in 2016, the new and relevant ones are the ones using "gsettings". Which one did you exactly follow? "I want my gnome-terminal instances to always display" - is it really gnome-terminal itelf (the entire window) that no longer displays for you, or the cursor? "when I move the terminal with an arrow key" - how do you move the terminal with an arrow key, didn't you mean the cursor? – egmont Aug 16 '18 at 11:37
  • Sorry, I meant the terminal cursor with the arrow key. My bad. – noname Aug 16 '18 at 15:41
0

If you open up gnome-terminal, go to the Activities bar, and open the menu for Terminal. Click Preferences. Under Profiles, you should see at least one profile. Select the one in use (if there are multiple).

The setting you're looking for will be in the Text section. Find the Cursor heading, where there will be a Cursor blinking option. Set that to Disabled.

  • I don't have a text section. Under General I have Text Appearance but that does not have any 'Cursor blinking' option. – noname Aug 15 '18 at 18:59
  • Are you able to post a screenshot of the preferences window? – hiigaran Aug 15 '18 at 19:08
  • Sure it is edited in. – noname Aug 15 '18 at 19:29
  • I just realised that you've mentioned you're running 16.04, which is why I was referring to settings available in 18.04. If we go back to the question you linked, the second answer has a couple of comments referencing the UUID of the profile you have. In your screenshot, it's called Profile ID. Have you tried setting that same terminal solution while using your UUID? – hiigaran Aug 16 '18 at 2:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.