I usually run the Software Updater when I switch on my desktop each morning. Very often I sit and wait while it displays this message:

waiting for packagekitd to exit

And looks like this:

enter image description here

I've done some websearching on this, and in spite of a couple mentions on Unix.SE, I haven't succeeded in finding out what "packagekitd" is, why I "wait" for it so often (can be a matter of minutes, not seconds), and whether I can avoid this somehow. My goal is to prevent packagekitd from hijacking my updating process.

Help appreciated! I'm running plain Ubuntu 18.04 LTS.


1 Answer 1


PackageKit is a system made to use the distribution's software installation and update tools easier. You can read more about it here: https://www.freedesktop.org/software/PackageKit/pk-intro.html

You can stop packagekitd with the command:

systemctl stop packagekit

If, for some reason, you wish to disable it, you can use:

systemctl disable packagekit
  • 3
    Or if you really want to get rid of it, "sudo apt-get -s purge packagekit". Check for dependencies, but in my case, they were non-consequential. My final go used "sudo apt-get purge packagekit appstream apt-config-icons" to remove the extra cruft.
    – dave58
    Jun 20, 2020 at 21:31
  • solution I am looking for is to simply delay the launch of packagekit until a few minutes after a reboot not almost immediately ... either as a parameter or by inserting a wrapper to replace its launch which just sleeps for 10 minutes before launching packagekit Feb 1 at 15:40
  • @scott-stensland- You could put that stop command in crontab (@reboot) and then another "@reboot sleep 600 && systemctl start package" after that.
    – DocWeird
    Feb 2 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.