0

I have a two month old Intel NUC8i7HNK, and when I saw Vega M support go out in kernel v4.18 I decided to make the unwise decision of upgrading the kernel of my perfectly stable 18.04 install to this new release. After I installed the kernel and restarted, I came back to a "purple screen of death". I restarted again and tried to jump into grub to boot the old kernel, but my keyboard didn't respond at all and it actually went to grub, but to no avail. It counted down 30 seconds and went straight back to PSoD.

I have no other keyboard(can report that keyboard still works fine on a MacBook Air). The keyboard does not respond at any point of the bootstrap process - can't even enable caps lock, num lock, or even switching keyboard configurations on my Kinsesis Advantage2. A connected USB hub does receive power but the keyboard will not, even through that hub or the port the hub is plugged in to.

After loading the PSoD, the computer does nothing at all visually. The processor seems to be completely idle. Unfortunately can't post any logs.

Update:. Starting the machine with only the keyboard attached (no display) makes it actually do something(and the keyboard at least makes sounds when you press e.g. caps lock), though plugging the display after the boot does nothing - making it hard to know what it is doing.

Update 2:. Tried with the SSD removed, got the "bootable device not detected" error as expected, but still unable to enter bios(keyboard inoperable).

  • I guess I should have mentioned that I had no prior issues with this keyboard for entering bios before – Anthony Bullard Aug 15 '18 at 1:13
  • Is this question really how to interrupt grub countdown? – WinEunuuchs2Unix Aug 15 '18 at 1:42
  • If you mean without a working keyboard @WinEunuuchs2Unix – Anthony Bullard Aug 15 '18 at 1:58
0

So, the solution ended up being kind of ridiculous. I used a USB-A to USB-C adapter and plugged my keyboard into the rear USB-C port on the machine and it worked perfectly. I now was able to log into my system with 4.15.32 and relax.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.