I've installed GoG Heroes III Complete using Wine on Ubuntu 18.04 on an Acer Aspire TimelineX 5830TG laptop. When running the game, I see that some keyboard shortcuts won't work. For example, n to select New Game, r to select Random Mode, e to end turn, t to select city. However, Esc works to exit game, and Enter works for confirming selection.

I've stumbled upon this thread here: keyboard not working with games in wine which I hoped will help me, but after following it closely I had no luck.

I've tried changing Windows version in winecfg from XP to 7 to 8 to 10, but nothing happened.

I've tried switching Ubuntu's native input method from default to ibus and back, also with no results.

Any hope I fix this?

  • Thanks for the advice @K7AAY. I've added the information as well as I could. My computer is a laptop and the keyboard is built in, but I'm like 99.9% sure this issue is on the software side, as the keyboard itself works flawlessly everywhere else. – Томица Кораћ Aug 17 '18 at 5:22
  • Does the problem occur when you use a USB external keyboard attached to the laptop? – K7AAY Aug 17 '18 at 16:44
  • 1
    I'm having the same problem, found no solution yet. However, that doesn't apply to all games. Baldur's Gate works fine, while Fallouts suffer the issue. Also, numerical keys works fine. I'm looking into wine debug/DX codes for now. Edit: confirmed that keys are working in OpenBox, but not x11 or Wayland. It's something about window manager. – burner1024 Aug 20 '18 at 20:20
  • @burner1024 thanks. I suspected it's related to the window manager, as there was no problem at all on Ubuntu 16.10 i.e. Unity, but now exists on Ubuntu 18.04 with Gnome Shell. Still looking for a solution though. Is it perhaps advisable to report a bug somewhere? Maybe to WINE crew? – Томица Кораћ Aug 22 '18 at 13:52
  • I just switched from Ubuntu Gnome (default for Bionic) to Unity and the keyboard works just fine. So in addition to OpenBox, Unity works too. But not Gnome Shell. – Томица Кораћ Aug 26 '18 at 8:38

I as well ended up switching to Unity. The problem is somewhere in the type of the window manager. Apparently Wine needs a stacking one, and Gnome Shell (Mutter), is compositing. Related links:

2 notes, however:

  1. I'm pretty sure it worked fine in Ubuntu 17.10 with Shell...
  2. Compiz is compositing, too. I guess it's just smarter than Mutter, which, according to the above link, has approxiately 5 settings.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.