I have Oracle VM VirtualBox 5.1.38 installed for long time:

$ apt-cache policy virtualbox-5.1 
  Installed: 5.1.38-122592~Ubuntu~xenial
  Candidate: 5.1.38-122592~Ubuntu~xenial
  Version table:
 *** 5.1.38-122592~Ubuntu~xenial 500
        500 http://download.virtualbox.org/virtualbox/debian xenial/contrib amd64 Packages
        100 /var/lib/dpkg/status

I have not ran kernel updates, or something DKMS-related today.

The problem started with "Implementation of the USB 2.0 controller not found!" as in this Q&A.

So I downloaded corresponding version of Oracle VM VirtualBox Extension Pack and tried to install it by clicking on the file in ~/Downloads folder.

Then VirtualBox opened, suggested me to install extpack:

VirtualBox question

I clicked Install and accepted license.

Then the following error window was shown:

VirtualBox - Error

The installer failed with exit code 127: Error creating textual authentication agent: Error opening current controlling terminal for the process (`/dev/tty'): No such device or address.

Same with console way of installation:

$ VBoxManage extpack install ~/Downloads/Oracle_VM_VirtualBox_Extension_Pack-5.1.38.vbox-extpack 
VirtualBox Extension Pack Personal Use and Evaluation License (PUEL)
Do you agree to these license terms and conditions (y/n)? y

License accepted. For batch installaltion add
to the VBoxManage command line.

Progress state: NS_ERROR_FAILURE
VBoxManage: error: Failed to install "/home/norbert/Downloads/Oracle_VM_VirtualBox_Extension_Pack-5.1.38.vbox-extpack"
VBoxManage: error: The installer failed with exit code 127: Error creating textual authentication agent: Error opening current controlling terminal for the process (`/dev/tty'): No such device or address
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ExtPackManagerWrap, interface IExtPackManager
VBoxManage: error: Context: "RTEXITCODE handleExtPack(HandlerArg*)" at line 1201 of file VBoxManageMisc.cpp

My user is a member of vboxusers group.

What to do with this?

2 Answers 2


Virtualbox Extension Pack needs to be installed using root powers according to these bug reports:

Stack Exchange has the latest installation instructions

LatestVirtualBoxVersion=$(wget -qO - http://download.virtualbox.org/virtualbox/LATEST.TXT) && wget "http://download.virtualbox.org/virtualbox/${LatestVirtualBoxVersion}/Oracle_VM_VirtualBox_Extension_Pack-${LatestVirtualBoxVersion}.vbox-extpack"
sudo VBoxManage extpack install --replace Oracle_VM_VirtualBox_Extension_Pack-${LatestVirtualBoxVersion}.vbox-extpack
VBoxManage list extpacks
  • Thank you very much! I was in hurry, so I solved this issue with GUI and terminal ways. But your answer is great because of LatestVirtualBoxVersion part.
    – N0rbert
    Aug 14, 2018 at 11:09
  • 1
    Thank you. It was good timed question because I installing VB Ext Pack is on my to-do list. I think this thread can help many people down the road. Aug 14, 2018 at 11:30

Any of the following methods will solve the issue:

* GUI way

  1. Run VirtualBox as root

     sudo virtualbox
  2. Go to File→Preferences (or Ctrl+G)

  3. Open Extensions tab

  4. Click top right button Add new package labeled with Add new package.

  5. Select downloaded extpack, click Install, agree with license

  6. Close VirtualBox

Then open VirtualBox as normal user and repeat steps 2-5 again.

* Terminal way

Install with VBoxManage command:

$ sudo VBoxManage extpack install \
Successfully installed "Oracle VM VirtualBox Extension Pack".

As the result it is shown in Preferences→Extensions:

ExtPack installed

and in terminal:

$ vboxmanage list extpacks
Extension Packs: 1
Pack no. 0:   Oracle VM VirtualBox Extension Pack
Version:      5.1.38
Revision:     122592
Description:  USB 2.0 and USB 3.0 Host Controller, Host Webcam, VirtualBox RDP, PXE ROM, Disk Encryption, NVMe.
VRDE Module:  VBoxVRDP
Usable:       true 
Why unusable: 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.