1

after I've reinstalled Ubuntu, I've been unable to play sound from my (internal) speakers since. There are only headphones available, even when there are no headphones plugged in. In Settings > Sound simply isn't the speakers. I dual boot with Windows 10, which play sound from speakers without problems.

I've tried a lot of things, including reinstalling various packages. The solution that almost worked is here: No sound from speakers, but headphones work

I've edited the file /etc/modprobe.d/alsa-base.conf and added line options snd-hda-intel model=generic. This added display port to options > sound menu. I've tried to play sound with my display port, but it obviously didn't work.

I think the issue may be in the file because I'm missing the speakers' option from settings > sound menu.

Latest Ubuntu (18), everything updated. Ask for additional information if you need any, I'll edit my post and add them here.

lspci -nnk | awk -v n='[0403]' 'p&&/^\S/{p=0}!p{p=index($0,n)}p'

aplay -l

pactl list short sinks:

0   alsa_output.pci-0000_00_1b.0.analog-stereo  module-alsa-card.c  s16le 2ch 44100Hz   SUSPENDED

Edit: After I reinstalled my system, the solutiom from @OpenSage started working. Thanks OpenSage!

  • @DavidFoerster Thank you, I've edited my post and added outputs of the commands. In alsamixer, I've turned everything on and it didn't help. The bass speaker was turned off and I cannot turn it on, it doesn't go higher than 0. The speaker looks normal. – SoptikHa Aug 14 '18 at 8:07
  • There may be other module options set via modprobe. What's the output of grep -Fe snd-hda-intel /etc/modules /etc/modprobe.d/*.conf? – David Foerster Aug 14 '18 at 8:45
  • @DavidFoerster nothing - there is no output. /etc/modules is empty (there are only comments there), cat /etc/modprobe.d/*.conf output is here – SoptikHa Aug 14 '18 at 10:08
0

Maybe try this. Open your terminal and type in sudo apt-get install pavucontrol

After it has been installed search your applications for PulseAudio Volume Control and open it.

A gui will have many different options for inputs, playback, recording, etc.

One more thing you might try is to plug headphones into the jack and pull them back out right away. Hope this will help in some way.

  • This doesn't work. In the volume control, there are two ports. Headphones (plugged in) - which are not plugged in and speakers (unavailable). Even when I select speakers, I can't hear anything. – SoptikHa Aug 14 '18 at 10:16
  • This is weird, but after I reinstalled my OS, your solution started working. Thank you! – SoptikHa Feb 10 at 9:43
0

I've fixed it.

I've followed instructions on ubuntuforums.org and added following lines to /etc/modprobe.d/alsa-base.conf:

alias snd-card-0 snd-hda-intel 
alias sound-slot-0 snd-hda-intel 
options snd-hda-intel model=dell-m4-1 
options snd-hda-intel enable_msi=1

Some of them might be redundant, but I'm not going to test it, it works. These lines (after reboot) added Line Out Built-in Audio, which works and plays sound from speakers. Headphones that were always on the list even when they were unplugged are no longer on the list.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.