1

I have used terminator as my default terminal for years. Recently I found docker commands started requiring sudo to run, and while debugging this, discovered terminal emulators on my system (terminator, MATE Terminal, Xfce Terminal, XTerm) start without loading many of my user's groups.

In these emulators, running groups yields:

mark@mypc:~$ groups
mark

When I run groups in Gnome Terminal, however:

mark@mypc:~$ groups
mark adm cdrom sudo dip plugdev lpadmin sambashare docker

I have tried apt remove & purge terminator, and reinstalled, with the same result. From Gnome Terminal, I can run docker commands without sudo (which was my goal initially). However I would prefer to continue to use terminator as my default emulator. So, How can I have the terminal emulator start with all of my users groups enabled?

I have tried apt remove & purge terminator, and reinstalled, with the same result. However, when I user Gnome Terminal to launch Terminator, terminator starts with all of my user groups.

I'm using Ubunutu 18.04 with cinnamon desktop environment. Thanks in advance!

Output of pstree in broken terminator instance:

mark@mypc:~$ pstree -sp $$
systemd(1)───terminator(26282)───bash(26291)───pstree(26578)

Output of pstree in (working) Gnome Terminal:

mark@mypc:~$ pstree -sp $$
systemd(1)───systemd(3363)───gnome-terminal-(30711)───bash(22983)───pstree(24955)
13
  • @Ravexina Seems like an honest mistake. OP was adding details while I was editing the formatting. (and I just added back the changes that were lost.)
    – wjandrea
    Aug 13 '18 at 21:42
  • @wjandrea Yeah I figure it out ...
    – Ravexina
    Aug 13 '18 at 21:42
  • Sorry @wjandrea!
    – Mark S
    Aug 13 '18 at 21:49
  • 1
    @MarkS Open a terminal with issue like: "terminator", run: pstree -sp $$ also run it in "gnome-terminal" add the output to your question, it might be helpful to us spotting the problem.
    – Ravexina
    Aug 13 '18 at 21:50
  • 1
    I wonder if it's related to this: User not being initialized correctly on login Aug 13 '18 at 21:59
1

I tried the solution proposed here: https://unix.stackexchange.com/a/454715/292253, and the issue is resolved. In summary:

I just commented out the following lines in /etc/pam.d/lightdm

auth    optional        pam_kwallet.so
auth    optional        pam_kwallet5.so

and restart

Thanks for everyone's help!

1
  • 1
    I think I ran into this because I had started with kubuntu, then switched to ubuntu since gnome-shell works better in my vm. Thanks for sharing your solution.
    – David R.
    Sep 17 '19 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.