10

I have been encountering some trouble trying to boot 18.04. When I attempt to boot it becomes stuck "Started Hold until boot process finishes up", and ctrl+alt+f1/f2have no effect Following some instructions from the web I have tried booting into recovery mode to run networking and the execute some commands in the root shell. When I run network it freezes at "Flush Journal to Persistent Log". I have tried to fix that but I am quite new to Linux and have not been able to understand it. Any help is appreciated as I don't have the slightest idea of how to fix this. Thanks in advance for your time.

12

I had the exact same problem after a kernel upgrade. It turned out that my root partition was stuffed so much, it had no free space. I used the advanced mode menu to free up some space and restarted. It just worked afterwards.

  • 1
    Can you please tell how to enter advanced mode? – Calin Blaga Dec 17 '18 at 17:28
  • Select the "Advanced options for Ubuntu" item from the grub menu; it is usually located beneath the normal boot option. Then in order to free up some space, mount your root partition with write permission. Hope it helps. – Eli Dec 17 '18 at 21:30
  • I had to increase root partition size, advanced mode option did not free enough space. – C.S.Cameron Jan 15 '19 at 7:01
  • Thanks.. so helpful, it works for me!! – HISI Jul 26 '19 at 10:31
  • follow this one :wiki.ubuntu.com/RecoveryMode and than: #df -h, you can see that there is 0% dispo, you can remove some file from your /home or /, and than reboot, that s it !! – HISI Jul 26 '19 at 10:33
1

The same issue happened, when there was no free space on the disk.

To clean up you may go to root terminal and clean any not needed files. To do that you need while starting the system to press Shift(old systems) or Escape(new systems) button, then select booting in "recovery mode". Then select something like "root terminal". Clean up at least few G bytes. Type "exit" and choose option to "resume normal boot".

In any case, https://wiki.ubuntu.com/RecoveryMode should help you.

1

I really don't know why it happens, but have worked around and came up with a solution with. The solution steps are

  1. Change into tty. (!!!Yes you can change into tty)
  2. Enter the credentials and change into root user using sudo -s.
  3. Remove the Nvidia Driver which normally would have been there installed on your system. (I believe apt-get remove --purge '^nvidia-.*' will work as it is shown here how-can-i-uninstall-a-nvidia-driver-completely).
  4. Remove gdm(Gnome-display-Manager) which is normally the display managers for gnome desktop environments using command apt remove gdm.
  5. Re-install GDM using the command apt install gdm.
  6. Reboot the system using the command reboot.
  7. The above has to work and you would see the login screen again. Incase the above method works, you will need to re-install the Nvidia-drivers. I am sure there is a way you will work around it as it is completey graphical.

(SRY peeps, I myself am not an Ubuntu user, but have been long for 3 years. Have shifted to some other distro and faced the same issue and fixed it using the above steps. I believe it will work the same way for Ubuntu as well. Give it as try, maybe it works for you)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.