0

I run Xubuntu 18.04 on a Toshiba L505 laptop with an i5-430M CPU. Is there any way I can limit the maximum CPU frequency? This can easily be done in Windows 7 (by limiting CPU to e.g. 70%). Also, there is no "/sys/devices/system/cpu/cpu0/cpufreq/".

  • If you don't have that directory, then either your processor doesn't support CPU frequency scaling or it is disabled in BIOS. Does your computer have the new location? /sys/devices/system/cpu/cpufreq/policy0 , which should have legacy links from the old locations. – Doug Smythies Aug 13 '18 at 23:32
  • @DougSmythies That directory is empty. I looked into the BIOS (there are no options to set CPU frequency). – Sumac Aug 14 '18 at 6:06
0

You could try to install the Cpufreq extension (https://extensions.gnome.org/extension/1082/cpufreq/) which should give you a gui to set the cpu limits.

  • I am not using Gnome. – Sumac Aug 14 '18 at 5:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.