2

This isn't a captive portal thing. I've tried a lot already. It's not that browser pages aren't coming up when I've established a connection on Starbucks wifi and haven't clicked on accept on the splash page; I can't even establish that initial connection to even have hope of navigating to the splash page. I try to ping google.com and the terminal says it's an unknown host.

I've tried restarting network manager at least 20 times. I've added the ip to /etc/resolv.conf. I've changed my mac address to my phone's. No dice on anything. Please help.

Other wifi works. I can get on wifi at home and McDonald's (which has a login screen, too). I don't understand why Starbucks hates me. I'm a noob running 16.04

EDIT: This is not the same as the guy trying to access aruba.odyssys.net or whatever (sorry that I'm not being super specific; I'm on my phone cuz no wifi). I have tried the suggestions from that thread. It also sounds like he had his browser try to redirect him, which makes it sound like he was able to establish some form of communication with a router/internet. My wifi connection symbol just buffers for a while, then stops and says I'm disconnected and goes blank. I get nothing. I can't ping 8.8.8.8. Nothing.

I've already said I can connect to other WiFi, even at McDonald's. I really don't understand what the issue here could be.

EDIT 2: According to the thread Can't connect to Google Starbucks wifi on Ubuntu 17.10, the following edit to /etc/hosts that I made should have fixed the issue (after restarting network-manager, which I've done maybe 50 times:

127.0.0.1       localhost
127.0.1.1       Horme
# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

172.31.98.196 aruba.odyssys.net

Since someone linked to another post with the github wireless-info.txt thing, here's my output for that. Hopefully this helps.

########## wireless info START ##########

Report from: 14 Aug 2018 21:25 CDT -0500

Booted last: 14 Aug 2018 00:00 CDT -0500

Script from: 10 Jan 2018 20:04 UTC +0000

##### release ###########################

Distributor ID: Ubuntu
Description:    Ubuntu 16.04.5 LTS
Release:    16.04
Codename:   xenial

##### kernel ############################

Linux 4.15.0-30-generic #32~16.04.1-Ubuntu SMP Thu Jul 26 20:25:39 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, net.ifnames=0, biosdevname=0, quiet, splash, vt.handoff=7

##### desktop ###########################

Ubuntu

##### lspci #############################

02:00.2 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 06)
    Subsystem: ASUSTeK Computer Inc. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [1043:200f]
    Kernel driver in use: r8169

03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Lite-On Communications Inc RTL8723BE PCIe Wireless Network Adapter [11ad:1723]
    Kernel driver in use: rtl8723be

##### lsusb #############################

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:b721 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 2386:310a  
Bus 001 Device 002: ID 13d3:5a01 IMC Networks 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

##### lsmod #############################

rtl8723be             102400  0
btcoexist             131072  1 rtl8723be
rtl8723_common         24576  1 rtl8723be
rtl_pci                32768  1 rtl8723be
rtlwifi                77824  4 rtl_pci,btcoexist,rtl8723_common,rtl8723be
mac80211              778240  3 rtl_pci,rtlwifi,rtl8723be
asus_nb_wmi            28672  0
cfg80211              622592  2 mac80211,rtlwifi
asus_wmi               28672  1 asus_nb_wmi
sparse_keymap          16384  1 asus_wmi
wmi_bmof               16384  0
wmi                    24576  2 asus_wmi,wmi_bmof
video                  45056  2 asus_wmi,i915

##### interfaces ########################

[/etc/network/interfaces]
auto lo
iface lo inet loopback

##### ifconfig ##########################

eth0      Link encap:Ethernet  HWaddr <MAC 'eth0' [IF1]>  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:270 errors:0 dropped:0 overruns:0 frame:0
          TX packets:270 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:20342 (20.3 KB)  TX bytes:20342 (20.3 KB)

wlan0     Link encap:Ethernet  HWaddr <MAC 'wlan0' [IF2]>  
          inet addr:192.168.0.105  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::9dc2:2932:fde7:4aae/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3160 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2880 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1839993 (1.8 MB)  TX bytes:643644 (643.6 KB)

##### iwconfig ##########################

eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11  ESSID:"Wazardy 2.4"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: <MAC 'Wazardy 2.4' [AN3]>   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-34 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:4   Missed beacon:0

##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    600    0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.0.0     0.0.0.0         255.255.255.0   U     600    0        0 wlan0

##### resolv.conf #######################

nameserver 8.8.8.8
nameserver 172.31.98.196

##### network managers ##################

Installed:

    NetworkManager

Running:

root       770     1  0 21:08 ?        00:00:01 /usr/sbin/NetworkManager --no-daemon

##### NetworkManager info ###############

GENERAL.DEVICE:                         wlan0
GENERAL.TYPE:                           wifi
GENERAL.NM-TYPE:                        NMDeviceWifi
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        RTL8723BE PCIe Wireless Network Adapter
GENERAL.DRIVER:                         rtl8723be
GENERAL.DRIVER-VERSION:                 4.15.0-30-generic
GENERAL.FIRMWARE-VERSION:               N/A
GENERAL.HWADDR:                         <MAC 'wlan0' [IF2]>
GENERAL.MTU:                            0
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.5/0000:03:00.0/net/wlan0
GENERAL.IP-IFACE:                       wlan0
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     Wazardy 2.4
GENERAL.CON-UUID:                       5e6934b0-9a0d-495d-847e-6489da17bb2b
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/0
GENERAL.METERED:                        no (guessed)
CAPABILITIES.CARRIER-DETECT:            no
CAPABILITIES.SPEED:                     72 Mb/s
CAPABILITIES.IS-SOFTWARE:               no
WIFI-PROPERTIES.WEP:                    yes
WIFI-PROPERTIES.WPA:                    yes
WIFI-PROPERTIES.WPA2:                   yes
WIFI-PROPERTIES.TKIP:                   yes
WIFI-PROPERTIES.CCMP:                   yes
WIFI-PROPERTIES.AP:                     yes
WIFI-PROPERTIES.ADHOC:                  yes
WIFI-PROPERTIES.2GHZ:                   yes
WIFI-PROPERTIES.5GHZ:                   no
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{2}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   5e6934b0-9a0d-495d-847e-6489da17bb2b | Wazardy 2.4
IP4.ADDRESS[1]:                         192.168.0.105/24
IP4.GATEWAY:                            192.168.0.1
IP4.ROUTE[1]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             8.8.8.8
DHCP4.OPTION[1]:                        requested_routers = 1
DHCP4.OPTION[2]:                        requested_domain_search = 1
DHCP4.OPTION[3]:                        requested_time_offset = 1
DHCP4.OPTION[4]:                        requested_domain_name = 1
DHCP4.OPTION[5]:                        requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[6]:                        requested_broadcast_address = 1
DHCP4.OPTION[7]:                        requested_netbios_scope = 1
DHCP4.OPTION[8]:                        requested_wpad = 1
DHCP4.OPTION[9]:                        next_server = 0.0.0.0
DHCP4.OPTION[10]:                       expiry = 1534306114
DHCP4.OPTION[11]:                       requested_interface_mtu = 1
DHCP4.OPTION[12]:                       requested_subnet_mask = 1
DHCP4.OPTION[13]:                       dhcp_lease_time = 7200
DHCP4.OPTION[14]:                       dhcp_message_type = 5
DHCP4.OPTION[15]:                       ip_address = 192.168.0.105
DHCP4.OPTION[16]:                       requested_static_routes = 1
DHCP4.OPTION[17]:                       requested_domain_name_servers = 1
DHCP4.OPTION[18]:                       routers = 192.168.0.1
DHCP4.OPTION[19]:                       broadcast_address = 192.168.0.255
DHCP4.OPTION[20]:                       requested_ntp_servers = 1
DHCP4.OPTION[21]:                       requested_netbios_name_servers = 1
DHCP4.OPTION[22]:                       domain_name_servers = 8.8.8.8
DHCP4.OPTION[23]:                       requested_ms_classless_static_routes = 1
DHCP4.OPTION[24]:                       subnet_mask = 255.255.255.0
DHCP4.OPTION[25]:                       network_number = 192.168.0.0
DHCP4.OPTION[26]:                       requested_host_name = 1
DHCP4.OPTION[27]:                       dhcp_server_identifier = 192.168.0.1
IP6.ADDRESS[1]:                         fe80::9dc2:2932:fde7:4aae/64
IP6.GATEWAY:                            

GENERAL.DEVICE:                         eth0
GENERAL.TYPE:                           ethernet
GENERAL.NM-TYPE:                        NMDeviceEthernet
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
GENERAL.DRIVER:                         r8169
GENERAL.DRIVER-VERSION:                 2.3LK-NAPI
GENERAL.FIRMWARE-VERSION:               
GENERAL.HWADDR:                         <MAC 'eth0' [IF1]>
GENERAL.MTU:                            1500
GENERAL.STATE:                          20 (unavailable)
GENERAL.REASON:                         2 (Device is now managed)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.4/0000:02:00.2/net/eth0
GENERAL.IP-IFACE:                       
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     --
GENERAL.CON-UUID:                       --
GENERAL.CON-PATH:                       --
GENERAL.METERED:                        unknown
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     unknown
CAPABILITIES.IS-SOFTWARE:               no
WIRED-PROPERTIES.CARRIER:               off
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: 

SSID                           BSSID              MODE   CHAN  FREQ      RATE       SIGNAL  BARS  SECURITY   ACTIVE  * 
lowrider                       <MAC 'lowrider' [AN1]>  Infra  1     2412 MHz  54 Mbit/s  100     ▂▄▆█  WPA2       no        
--                             <MAC '--' [AN2]>  Infra  6     2437 MHz  54 Mbit/s  100     ▂▄▆█  --         no        
Wazardy 2.4                    <MAC 'Wazardy 2.4' [AN3]>  Infra  6     2437 MHz  54 Mbit/s  90      ▂▄▆█  WPA1 WPA2  yes     * 
ATT94lvt3m                     <MAC 'ATT94lvt3m' [AN4]>  Infra  9     2452 MHz  54 Mbit/s  90      ▂▄▆█  WPA2       no        
--                             <MAC '--' [AN5]>  Infra  6     2437 MHz  54 Mbit/s  77      ▂▄▆_  --         no        
HOME-2232                      <MAC 'HOME-2232' [AN6]>  Infra  1     2412 MHz  54 Mbit/s  74      ▂▄▆_  WPA1 WPA2  no        
xfinitywifi                    <MAC 'xfinitywifi' [AN7]>  Infra  1     2412 MHz  54 Mbit/s  70      ▂▄▆_  --         no        
DIRECT-5C-HP ENVY 4510 series  <MAC 'DIRECT-5C-HP ENVY 4510 series' [AN8]>  Infra  6     2437 MHz  54 Mbit/s  70      ▂▄▆_  WPA2       no        

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono

[ifupdown]
managed=false

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/DGPL-Pub]] (600 root)
[connection] id=DGPL-Pub | type=wifi | permissions=user:michael:;
[wifi] mac-address=<MAC 'wlan0' [IF2]> | mac-address-blacklist= | ssid=DGPL-Pub
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/PEETS]] (600 root)
[connection] id=PEETS | type=wifi | permissions=
[wifi] mac-address=<MAC 'wlan0' [IF2]> | mac-address-blacklist= | ssid=PEETS
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/McDonalds Free WiFi]] (600 root)
[connection] id=McDonalds Free WiFi | type=wifi | permissions=user:michael:;
[wifi] mac-address=<MAC 'wlan0' [IF2]> | mac-address-blacklist= | ssid=McDonalds Free WiFi
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/PEETS 1]] (600 root)
[connection] id=PEETS 1 | type=wifi | permissions=user:michael:;
[wifi] mac-address=<MAC 'wlan0' [IF2]> | mac-address-blacklist= | ssid=PEETS
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Google Starbucks 1]] (600 root)
[connection] id=Google Starbucks 1 | type=wifi | permissions=user:guest-zv0xwj:;
[wifi] mac-address=<MAC 'wlan0' [IF2]> | mac-address-blacklist= | ssid=Google Starbucks
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/CBCI-4022-2.4]] (600 root)
[connection] id=CBCI-4022-2.4 | type=wifi | permissions=
[wifi] mac-address=<MAC 'wlan0' [IF2]> | mac-address-blacklist= | ssid=CBCI-4022-2.4
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Wazardy 2.4]] (600 root)
[connection] id=Wazardy 2.4 | type=wifi | permissions=
[wifi] mac-address=<MAC 'wlan0' [IF2]> | mac-address-blacklist= | ssid=Wazardy 2.4
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Google Starbucks]] (600 root)
[connection] id=Google Starbucks | type=wifi | permissions=user:michael:;
[wifi] mac-address=<MAC 'wlan0' [IF2]> | mac-address-blacklist= | ssid=Google Starbucks
[ipv4] method=auto
[ipv6] method=auto

##### Netplan config ####################

##### iw reg get ########################

Region: America/Chicago (based on set time zone)

country US: DFS-FCC
    (2402 - 2472 @ 40), (N/A, 30), (N/A)
    (5170 - 5250 @ 80), (N/A, 23), (N/A)
    (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS
    (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
    (5735 - 5835 @ 80), (N/A, 30), (N/A)
    (57240 - 63720 @ 2160), (N/A, 40), (N/A)

##### iwlist channels ###################

eth0      no frequency information.

lo        no frequency information.

wlan0     11 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Current Frequency:2.437 GHz (Channel 6)

##### iwlist scan #######################

eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlan0     Interface doesn't support scanning : Device or resource busy

##### module infos ######################

[rtl8723be]
filename:       /lib/modules/4.15.0-30-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw_36.bin
firmware:       rtlwifi/rtl8723befw.bin
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         PageHe  <page_he@realsil.com.cn>
srcversion:     6A56582B1FEECB841E329C4
depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
retpoline:      Y
intree:         Y
name:           rtl8723be
vermagic:       4.15.0-30-generic SMP mod_unload 
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           aspm:Set to 1 to enable ASPM (default 1)
 (int)
parm:           debug_level:Set debug level (0-5) (default 0) (int)
parm:           debug_mask:Set debug mask (default 0) (ullong)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)
parm:           ant_sel:Set to 1 or 2 to force antenna number (default 0)
 (int)

[rtl8723_common]
filename:       /lib/modules/4.15.0-30-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723com/rtl8723-common.ko
description:    Realtek RTL8723AE/RTL8723BE 802.11n PCI wireless common routines
license:        GPL
author:         Larry Finger    <Larry.Finger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
srcversion:     90DB9C652E26F4135F339B8
depends:        rtlwifi
retpoline:      Y
intree:         Y
name:           rtl8723_common
vermagic:       4.15.0-30-generic SMP mod_unload 

[rtl_pci]
filename:       /lib/modules/4.15.0-30-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl_pci.ko
description:    PCI basic driver for rtlwifi
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         lizhaoming  <chaoming_li@realsil.com.cn>
srcversion:     9F5FA8A771710F4CA500C6E
depends:        mac80211,rtlwifi
retpoline:      Y
intree:         Y
name:           rtl_pci
vermagic:       4.15.0-30-generic SMP mod_unload 

[rtlwifi]
filename:       /lib/modules/4.15.0-30-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtlwifi.ko
description:    Realtek 802.11n PCI wireless core
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         lizhaoming  <chaoming_li@realsil.com.cn>
srcversion:     8AB8B2AAF3BCFFB93D91956
depends:        mac80211,cfg80211
retpoline:      Y
intree:         Y
name:           rtlwifi
vermagic:       4.15.0-30-generic SMP mod_unload 

[mac80211]
filename:       /lib/modules/4.15.0-30-generic/kernel/net/mac80211/mac80211.ko
license:        GPL
description:    IEEE 802.11 subsystem
srcversion:     1CEA5CF286EDB289C1D0BF8
depends:        cfg80211
retpoline:      Y
intree:         Y
name:           mac80211
vermagic:       4.15.0-30-generic SMP mod_unload 
parm:           minstrel_vht_only:Use only VHT rates when VHT is supported by sta. (bool)
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/4.15.0-30-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     D5B0789D4C423C81CCFB437
depends:        
retpoline:      Y
intree:         Y
name:           cfg80211
vermagic:       4.15.0-30-generic SMP mod_unload 
parm:           bss_entries_limit:limit to number of scan BSS entries (per wiphy, default 1000) (int)
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[rtl8723be]
ant_sel: 0
aspm: 1
debug_level: 0
debug_mask: 0
disable_watchdog: N
fwlps: Y
ips: Y
msi: N
swenc: N
swlps: N

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
minstrel_vht_only: Y
probe_wait_ms: 500

[cfg80211]
bss_entries_limit: 1000
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

##### modprobe options ##################

[/etc/modprobe.d/amd64-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/intel-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

##### rc.local ##########################

exit 0

##### pm-utils ##########################

grep: /etc/pm/config.d/.config.swp: Permission denied

##### udev rules ########################

##### dmesg #############################

########## wireless info END ############
  • My wireless works at home, though. I don't think it's necessarily a hardware issue. I'm also now noticing that each time I try to connect to the WiFi, it adds a new WiFi connection in the list of connections. Like, I'll try editing the connection for "Google Starbucks", but once I do that and click to connect again, "Google Starbucks 1" shows up in my connections. – OrdinalDefinable Aug 13 '18 at 21:21
  • 1
    Please do not post screenshots of the terminal. Paste the text directly to your question and apply code formatting. – Melebius Aug 15 '18 at 7:55
  • 1
    Welcome to Ask Ubuntu! From where did you get the IP address 172.31.98.196? It doesn't appear in the list of available routes like the accepted answer to the linked question suggests. – David Foerster Aug 15 '18 at 11:14
  • That IP was what I got from my phone when I connected to the wifi – OrdinalDefinable Aug 15 '18 at 16:56
  • I got termux on my phone and ran ip route there. It looks like I did want 172.31.98.1, but that still didn't fix my issue. – OrdinalDefinable Aug 15 '18 at 17:31
2

In my experience with Ubuntu 14.04 and 16.04, Android 4.4 and 8.1, and (my partner's) Mac Sierra, it's now pretty much a requirement that, after selecting (or auto-selecting) the Starbuck's Wifi, you must open a browser and attempt to load https://www.google.com. You might get away with abbreviating (for instance, just typing google.com in your address bar), and it works to use a stored bookmark, as long as it's to the main Google search page.

As far as I've been able to determine, there is no other reliable way to trigger the Starbuck's auto-login page or the one that asks your email address and promises your computer will automatically connect in the future -- but this works every single time, with multiple browsers (Firefox, SeaMonkey, Chrome, Safari) across multiple OS platforms.

2

Have had this same issue repeatedly over the last few weeks at Starbucks. It's a known issue, according to the Google Tech I contacted (they've had a bunch of complaints).

Here is how I was told to fix it: (and it's worked)

  1. System Preferences > Network > WiFi in left pane, delete (click the - button) and click Apply to save.
  2. Restart the computer
  3. System Preferences > Network Click + Add WiFi, Click Apply to save.
  4. Connect to Google Starbucks network
  5. Open Chrome and go to red.com, or access the network portal page as you usually would.

If that doesn't work:

Clear Your Chrome Cache:

  1. Three dots on far right of Chrome More Tools > Clear Browsing Data > Advanced > “All Time” + first four boxes checked > Clear Cache
  2. Close Chrome after Cache clears
  3. System Preferences > Network > Advanced > Select Google Starbucks in List on the Left Click -
  4. Open Chrome and go to red.com

Both of these have worked for me.

If you're having problems, you can connect w/ the Google WiFi Support Line at 855.446.2374.

1

I changed the settings on NordVPN not realizing that one of the changes would block the Google-Starbucks WiFi landing page from appearing. The setting is "Invisibility on LAN". The selections you make in the VPN application you are using are in effect even when you are not logged on. Turn it off and you are good to go. :)

  • Thank you, I tried everything else and never even thought of that. – Oliver Oberdorf Apr 6 at 14:24
1

If you are successful connecting to the network, but can't get the splash page to get internet access try:

Open terminal and run ifconfig

Should look like something along these lines (some information was removed):

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.0.9.191  netmask 255.255.255.0  broadcast 10.0.9.255
        prefixlen 64  scopeid 0x20<link>
        txqueuelen 1000  (Ethernet)
        RX packets 369116  bytes 534215839 (509.4 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 125398  bytes 12433551 (11.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

10.0.9.191 is your IP address. In this example, take this IP and paste it in your broswer. Then change 191 to 1 and press Enter to attempt a connection to the router's interface.

This should trigger a security policy on the router, that would throw you into the splash page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.