3

My printer no longer shows up in my Settings -> Devices GUI menu. Instead it says "Sorry! The system printing service doesn't seem to be available."

I tried searching the 'net for ideas and I ran these terminal commands with the following output:

john@john-max:~$ sudo service cups restart
john@john-max:~$ systemctl status cups

● cups.service - CUPS Scheduler
   Loaded: loaded (/lib/systemd/system/cups.service; enabled; vendor preset: enabled)
   Active: failed (Result: start-limit-hit) since Mon 2018-08-13 15:07:46 EDT; 14s ago
     Docs: man:cupsd(8)
  Process: 3314 ExecStart=/usr/sbin/cupsd -l (code=killed, signal=TERM)
 Main PID: 3314 (code=killed, signal=TERM)
Aug 13 15:07:46 john-max systemd[1]: cups.service: Service hold-off time over, scheduling restart.
Aug 13 15:07:46 john-max systemd[1]: cups.service: Scheduled restart job, restart counter is at 5.
Aug 13 15:07:46 john-max systemd[1]: Stopped CUPS Scheduler.
Aug 13 15:07:46 john-max systemd[1]: cups.service: Start request repeated too quickly.
Aug 13 15:07:46 john-max systemd[1]: cups.service: Failed with result 'start-limit-hit'.
Aug 13 15:07:46 john-max systemd[1]: Failed to start CUPS Scheduler.

john@john-max:~$ sudo apt-get install cups
Reading package lists... Done
Building dependency tree       
Reading state information... Done
cups is already the newest version (2.2.7-1ubuntu2.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

One thing which might matter: I recently opened Startup Applications and accidentally over-deleted some things there and don't know what they were. Maybe something for the printer service was in there?

I also tried re-installing my printer drivers for my printer but it just says already installed.

On Ubutnu Software as well as by running

sudo apt-get update && sudo apt-get upgrade

I show my software as all up to date.

I'm fairly novice so if you tell me what to do, if possible, please give me the actual terminal command.

  • Did you run sudo apt-get install --reinstall cups – George Udosen Aug 13 '18 at 20:08
  • Thanks for the reply. Yes I did that, and that ran, and when it was done I restarted my system. But when it was all over my GUI Settings-Devices screen still says: "Sorry! The printing service doesn't seem to be available.", and if I run 'systemctl status cups' it still says 'Failed to start CUPS Scheduler.' in red at the end. – Jerry777 Aug 31 '18 at 3:31
  • What's the next step, please? The only thing unusual I was doing before all this problem started was I was trying to install some extended Ubuntu video codecs from the command line. The printer was working on this OS before I did that. – Jerry777 Aug 31 '18 at 3:37
  • I don't have time to learn all about CUPS just to fix this. I'm thinking to reinstall Ubuntu which would take less time. – Jerry777 Aug 31 '18 at 3:41
  • As you wish but do a backup of important data before reinstalling – George Udosen Aug 31 '18 at 5:34
4

I had same problem. Config file is incorrectly located. Follow directions as per this link. https://ubuntu-mate.community/t/cups-service-stopped-um-18-04/17381

There is a default configuration file which should be installed in /usr/share/cups/cupsd.conf.default so I ran:

sudo cp /usr/share/cups/cupsd.conf.default /etc/cups/cupsd.conf
sudo service cups restart
  • Sorry that's too complicated for me – Jerry777 Dec 19 '18 at 9:11
  • This fixed the issue for me. I believe that it should be the accepted answer. – jon3laze Mar 7 at 5:06
0

I fixed the problem by uninstalling Ubuntu 18.04 and reinstalling Ubuntu 16.04. Now not only the printer works, but the scanner too. Good thing there's Long Term Support.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.