So at first even the brightness key (via Fn button) used to work in Ubuntu 18.04. After an update, i can't even change it from the setting. And with the keys, it just show the icon of the screen brightness which is changing, and doesn't actually do anything.

To be mentioned, with brightness-controller-simple which is suggested in this answer, the "actual" brightness doesn't change, it just makes the colors more dark, with same amount of light coming out of the screen. The xbacklight also doesn't work; I mean, this command doesn't do a thing xbacklight -inc 10, which is suggested here.

I finally could change the actual brightness, but from the terminal command which i read here. Which is this command:

sudo bash -c "echo 130 > /sys/class/backlight/intel_backlight/brightness;"

Is there any other way i could probably change the brightness?

I have ASUS model V502U. And results from lspci -v | less, video adapter part:

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07) (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Skylake GT2 [HD Graphics 520]
Flags: bus master, fast devsel, latency 0, IRQ 129
Memory at dd000000 (64-bit, non-prefetchable) [size=16M]
Memory at b0000000 (64-bit, prefetchable) [size=256M]
I/O ports at f000 [size=64]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915
  • It would be constructive to click on the edit link above and to the left, and note the make and model of your laptop or all-in-one machine. Please get the model number from the serial number plate, not the top of front of the PC, as the model number from the serial number plate is much more helpful. Also, please run lspci -v | less and also paste the video adapter information into the original post.
    – K7AAY
    Aug 13, 2018 at 17:38
  • @K7AAY Should i post the whole results from lspci -v | less?
    – Shayan
    Aug 13, 2018 at 17:53
  • The video adapter information only.
    – K7AAY
    Aug 13, 2018 at 17:55

6 Answers 6


I found an answer, but not the best one!

Read this, to change the /etc/X11/xorg.conf file.

I did the solution from that post, and installed the new updates, then xbacklight worked. But still, I couldn't change the brightness from setting. According to this answer, you can increase the screen brightness by 10% by this command:

xbacklight -inc 10

And decrease the brightness by 10% by this command:

xbacklight -dec 10

Then create a keyboard shortcut, for intsance, shift+f9 for command xbacklight -inc 10, or so. Unfortunately, it doesn't let you use fn+f9 shortcut, since it is supposed to have a job itself primitively.

  • $ sudo apt install xbacklight This works very well. I created the following custom hotkeys: <Super><F4> for xbacklight -set 5 # Set to a reasonable lowest <Super><F5> for xbacklight -set 100 # Set to a highest
    – jlettvin
    Sep 19, 2018 at 13:55
  • 1
    'not the best one' - gets best rate
    – france1
    Aug 28, 2021 at 12:42

On Ubuntu 18.04 (with xfce desktop) my brightness problem finally solved.

I opened 'Onboard Settings' under the 'Settings' menu. If your desktop doesn't have one, you can download it from Software Center.

On the 'Onboard Preferences' window, click the Layout menu, then choose the 'Full Keyboard' (Desktop keyboard with edit and function keys). Click here to view the Onboard Settings window


In case the above suggestion doesn't help you. Here I am suggesting which might help you. I have installed fresh Ubuntu 18.04 LTS and landed at this problem. In case, you have Nvidia Graphics Driver. Please do the following: Edit (or create) inside /usr/share/X11/xorg.conf.d/10-nvidia.conf

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration"
    Option "RegistryDwords" "EnableBrightnessControl=1;" # Add this if it exists
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"


sudo vim /usr/share/X11/xorg.conf.d/10-nvidia.conf
Check with the above code.

We require "xrandr" command to view and set the screen on Ubuntu 18.

root@joe-UBTPC:/home/jarurote# xrandr

Screen 0: minimum 8 x 8, current 1600 x 900, maximum 32767 x 32767

eDP1 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 440mm x 250mm 1600x900 60.00*+ 59.82
1440x900 59.89
1400x900 59.96 59.88
1368x768 60.00 59.88 59.85
1360x768 59.80 59.96
1280x800 59.81 59.91
1152x864 60.00
1280x720 59.86 60.00 59.74
1024x768 60.00
1024x576 60.00 59.90 59.82
960x540 60.00 59.63 59.82
800x600 60.32 56.25
864x486 60.00 59.92 59.57
800x450 60.00
640x480 59.94
720x405 59.51 60.00 58.99
640x360 59.84 59.32 60.00

VGA1 disconnected (normal left inverted right x axis y axis)

VIRTUAL1 disconnected (normal left inverted right x axis y axis)




See that the 3rd line of output command shows the output screen of "eDP1".

To adjust the brightness of the screen, we can define the brightness of the screen in a range of [0.3, 1.0]. Suppose we need the brightness of 0.4, the command of xrandr should be like this.

xrandr --output eDP1 --brightness .4

That is it.

PS: Don't adjust the brightness value higher than 1.

  • 1
    This does not work as intended, as it only changes the color brightness via software, and does not change the backlight as requested.
    – SonicARG
    Jul 12, 2019 at 17:45

I had the same problem and the solution was changing the GRUB settings! (to change GRUB you must have superuser access)

edit your GRUB by running:

sudo nano /etc/default/grub

add acpi_backlight=vendor to GRUB_CMDLINE_LINUX_DEFAULT, so it should look like something like this (if you don't have additional parameters):

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

then you should update your GRUB by this command:

sudo update-grub

and after all, you must reboot your system for the changes to take effect:

sudo reboot

It is mostly because of driver issue. Installed driver and system configuration is not properly connected.

  1. Find the driver installed in your computer. search + software update > driver > additional driver
  2. In my case, I found that configuration was set to initialConfiguration which is not configured in system as well. so there is no way, Ubuntu can get configuration. So, we need to change it.

Mostly the path is:

sudo vim /usr/share/X11/xorg.conf.d/10-nvidia.conf or similar in /usr/share/X11/xorg.conf.d/* directory depending on step 1


Initially File should look like this:

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "AllowEmptyInitialConfiguration" # See this, configured to InitialConfig
    Option "RegistryDwords" "EnableBrightnessControl=1;" 
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"
Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "RegistryDwords" "EnableBrightnessControl=1;" # This is important
    ModulePath "/usr/lib/x86_64-linux-gnu/nvidia/xorg"

Then reboot and cheers!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .