I was trying to convert ogv video to avi using ffmpeg. It does convert without any error but the output video seems to be corrupt. Does not matter which format I convert it to, out put is same as shown in screenshot.

ffmpeg command : ffmpeg -i original.ogv -sameq converted.avi

ffmpeg version : 0.7

ubuntu : 11.10 - 64 bit

Original video screenshot

Original video screenshot

Converted video screenshot

Converted video screenshot

  • You cant expect same quality after video conversion i got the similar output after converting ogv file to mp4 file but file size doubled i tried winff(gui of ffmpeg)
    – Tachyons
    Feb 22, 2012 at 12:13
  • @AboobackerMk Its not about quality. Quality can be changed with appropriate parameters. Problem is, output video has distorted text and images as you can see in second screenshot.
    – Rojan
    Feb 22, 2012 at 12:20
  • you would have better results with ffmpeg -i original.ogv -sameq -f mp4 converted.mp4
    – duffydack
    Feb 22, 2012 at 12:27
  • @duffydack No luck, output is same. dl.dropbox.com/u/11067845/converted_mp4.png
    – Rojan
    Feb 22, 2012 at 12:34
  • 2 things to try then. 1: compile a newer ffmpeg/x264 from source ubuntuforums.org/showthread.php?t=786095 - it's simple. or 2: use kazam for screencasting, it uses webm as output
    – duffydack
    Feb 22, 2012 at 12:39

3 Answers 3


tl;dr: use Handbrake.

Ha. I had this exact issue with ffmpeg yesterday when making an animated gif for this question:

I used gtk-recordMyDesktop to record the screen but when I tried to do anything with ffmpeg, it just filled up with artefacts. To compound issues, I tried converting with desktop video editing software (I wanted to crop too) and they all just blew up. Probably something to do with the 3840x1200 frame size.

I'm sure there's a pure-ffmpeg for removing these artefacts but I just installed Handbrake and converted the ogv to a high-quality mp4 file, which I then used in ffmpeg to convert out to my animated gif.

Pain in the bum, but it doesn't take long for short clips, and in your case, it might even simplify things.

  • thanks for the workaround. Its certainly is pain in the bum :)
    – Rojan
    Feb 22, 2012 at 13:06
  • Thanks! Handbrake worked. ffmpeg and mencoder have the same bug, but Handbrake does not. Instructions on installing Handbrake for ubuntu can be found at askubuntu.com/questions/107915/… Feb 27, 2012 at 22:44

Two options at least for you.

  1. Install Kazam screencaster which supports outputting of webm format and compatible with uploading to Youtube where .OGV is not without conversion.

    sudo add-apt-repository ppa:kazam-team/unstable-series
    sudo apt-get update
    sudo apt-get install kazam
  2. Compile a newer ffmpeg from source to convert OGV. A very easy to follow guide is Compile latest FFMPEG and X264.


I had the same problem. Little squares everywhere in converted output from ogv. I tried mencoder and obtained the same result:

  mencoder original.ogv -vc theora -ovc x264 -o converted.avi

until I explicitly gave the -vc theora option:

  mencoder original.ogv -vc theora -ovc x264 -o converted.avi

This time the output was fine.

I also uninstalled ffmpeg 0.7.3, downloaded the latest source from the git repository, compiled and installed it. Now the same ffmpeg command converts ogv videos nicely.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.