I am at Settings > Bluetooth. I turned Bluetooth on in order to send a file to my phone and my ZTE Axon7 is listed under "Devices" as "Not set up". When I click on it, the rotating orange circle seems to indicate that it's trying something, but it soon returns to "Not set up".

$ bluetoothctl
[NEW] Controller 2C:33:7A:F2:00:F6 AWESOME-O [default]
[NEW] Device 18:68:6A:EE:7B:B9 ZTE AXON7
Agent registered
[bluetooth]# pair 18:68:6A:EE:7B:B9
Attempting to pair with 18:68:6A:EE:7B:B9
Failed to pair: org.bluez.Error.ConnectionAttemptFailed

I had entered "scan on", and "discoverable on" beforehand (as outlined in this Ubuntu Forums thread), but it doesn't seem to be necessary. I have also installed the latest version of TLP.

How can I connect my phone to my laptop in order to exchange files?

  • Suggestion: Ensure that the agent is registered as per this older answer. In terminal [bluetooth]#, run first agent on, default-agent, then only the pairing command. – user37165 Aug 27 '19 at 15:57
  • Try removing the device from Bluetooth settings, close settings. Then open settings and add your device – doug Aug 30 '19 at 13:41

I had a lot of problems with bluetooth, and navigating the array of settings was problematic. I found that blueman was a really handy interface for setting up devices.

sudo apt-get install blueman

And try pairing and connecting the devices through this tool?

I found that this tool displayed an error message when pairing a device that I hadn't managed to surface through other approaches.

  • Indeed, blueman-manager is the solutiion, all problems gone... Lost so much time with the default Ubuntu bluetooth handler :( – Breaking not so bad Apr 11 at 7:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.