1

How to reinstall broken Ubuntu (16.04) GUI and purging all the related libraries, and the packages installed from the sources related to the GUI ?

Firstly I tried to install the latest version at that time gedit 3.28.1, and I followed this walkthrough.
(I just realized that it wasn't the good version).

list of the installed packages

I was able to retrieve the "dpkg log" for the 3.28.1 in this pastebin.
At the same time, I noticed that I can't run a python program (pychess), because of a missing dependencie error.
After that I went for the 2.27.4 version of Gedit.

list of the installed packages and their dependencies for gedit 2.27.4

  1. Gspell 1.8.2
  2. Glib 2.49.4
  3. Gtk+-3.22.30

The dpkg log for this session is in this pastebin.

I ended loosing my terminal colors (all white with light foreground text), and when I restarted the machine, the Ubuntu splash screen and a black screen kept alternating and flickering I can however access the machine via a tty, or by booting in init3 mode. I reinstalled Ubuntu-desktop and Unity like this, but nothing changed

sudo apt remove ubuntu-desktop
sudo apt remove unity
sudo apt autoremove
sudo apt install ubuntu-desktop
sudo apt install unity

I was also unable to sudo apt checkinstall in the sources directories because of a missing library.
I also tried to boot in xfailsafe mode, It raised a Fatal server error: no screens found(EE).
Here is a copy of the log.

I am running Ubuntu 16.04.5 LTS.

lsb_release -a

LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch

Distributor ID: Ubuntu
Description: Ubuntu 16.04.5 LTS Release: 16.04
Codename: xenial

uname -a

Linux neo-box 4.7.0.intel.r5.0 #1 SMP Sun Jun 3 18:17:18 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux`

Is it possible to revert to the state previous to all this?

  • If I upgrade to another version will this fix the problem ? – Future Gadget Aug 13 '18 at 1:17
  • Since you say you installed software from source, upgrading Ubuntu seems unlikely to solve the problem (and might make the problem worse). – user535733 Aug 13 '18 at 2:11
  • Any clue how I can fix this ? – Future Gadget Aug 13 '18 at 2:20
  • 1
    Please edit your question to clarify exactly what you did, what changes you made to your system configs, what additional packages you installed, and whatever partial fixes you may have tried. Reinstalling the GUI is not very difficult...unless you have added new sources, wrong-version packages, or non-packaged software. We need to know details about all of those. – user535733 Aug 13 '18 at 3:33
  • If you want the most recent version of applications, please install the most recent version of Ubuntu. The version 18.04 includes Gedit 3.28.1. See also Why don't the Ubuntu repositories have the latest versions of software? – Melebius Aug 15 '18 at 6:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.