2

I am completely new to Linux so apologies in advance!

I recently installed Ubuntu 18.04 on a wiped machine and everything seems to work well except that it takes about 2 mins to boot.

Here are some details that might be useful for diagnostics (judging by other posts I've seen on similar issues).

The output of "systemd-analyze" is

Startup finished in 1min 43.839s (kernel) + 7.763s (userspace) = 1min 51.603s
graphical.target reached after 7.758s in userspace

The output of "sudo blkid" is

/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/loop4: TYPE="squashfs"
/dev/loop5: TYPE="squashfs"
/dev/loop6: TYPE="squashfs"
/dev/sda: PTUUID="8f39e0f9" PTTYPE="dos"
/dev/sdb5: UUID="92b37aee-3acf-447e-b15e-2fbb8a83e9a7" TYPE="ext4" PARTUUID="7ff18de1-05"
/dev/sdb6: UUID="21d2706c-8400-44f6-ad90-79d2dfb6384f" TYPE="swap" PARTUUID="7ff18de1-06"

(the sda is an older hard-drive (not SSD) that I want to just use for backing up some files).

The content of "/etc/fstab" is

UUID=92b37aee-3acf-447e-b15e-2fbb8a83e9a7 / ext4 errors=remount-ro 0 1
UUID=21d2706c-8400-44f6-ad90-79d2dfb6384f none swap sw 0 0

Hope this helps you diagnose my problem and suggest some things to try! Many thanks!

EDIT. In response to request here is the output of "systemd-analyze blame"

6.345s NetworkManager-wait-online.service
4.481s plymouth-quit-wait.service
834ms fwupd.service
639ms dev-sdb5.device
591ms ufw.service
459ms udisks2.service
448ms NetworkManager.service
442ms plymouth-start.service
395ms networkd-dispatcher.service
392ms snapd.service
294ms accounts-daemon.service
284ms dev-loop0.device
268ms ModemManager.service
264ms apparmor.service
256ms dev-loop2.device
243ms dev-loop3.device
238ms dev-loop1.device
213ms systemd-logind.service
197ms dev-loop4.device
191ms snap-gnome\x2dcalculator-180.mount
181ms dev-loop5.device
170ms systemd-timesyncd.service
166ms systemd-udevd.service

It goes on but they're all very small times (should I still list them?)

  • Please add output of systemd-analyze blame to the question. If you see many /dev/loop devices, read this answer. – N0rbert Aug 12 '18 at 19:54
  • Added systemd-analyze blame output – user350031 Aug 12 '18 at 19:59
  • I do not see anything critical here. – N0rbert Aug 12 '18 at 20:00
  • But why is the "kernel" taking over 90s during boot? Is that normal? – user350031 Aug 12 '18 at 20:01
  • I have the same question about the kernel, you are right. But userspace loaded fasty. For kernel you can try to investigate logs for errors (journalctl --dmesg, /var/log/syslog, /var/log/kern.log, /var/log/boot.log). – N0rbert Aug 12 '18 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.