4

I recently updated Acer Aspire E5-552 from 16.04 LTS to 18.04 LTS. After the update, every time I suspend by system by closing the lid or being idle for a while, my system goes into shutdown instead of suspend.

uname -a yields

Linux mathijs-Aspire-E5-552 4.17.13-041713-generic #201808061132 SMP Mon Aug 6 15:34:37 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

When reverting to kernel 4.04, my system resumes correctly after suspend. However, kernel 4.04 cannot find my network card, thus reverting back to kernel 4.04 is not an option.

I also changed all behaviour in gnome-tweaks from suspend to hibernate, to no success.

I already tried various ways of altering grub like https://ubuntuforums.org/showthread.php?t=1556934, but to no avail. Setting the behavious to 'do nothing' like Laptop suspends on shutdown with lid closed does also not provide satisfying results, as my laptop drains much power or can overheat if lid close does nothing. I tried editing login.conf but to no avail.

Does someone know what might be wrong?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.