0

after installing Ubuntu 18.04 (fresh install, no upgrade), I spent some time to get a workspace grid with my previous keyboard shortcuts working (see Workspace layout in Ubuntu 18.04 [duplicate] and Ubuntu 18.04: Put window into screen corner).

This basically works fine, but it interferes with the keyboard shortcuts to split the view ("Maximize window", "Restore window", "View split on left", "View split on right") using the Super+Arrow key combinations.

When setting my shortcuts, these are replaced and everything is fine. But after a reboot, the view splitting shortcuts are set again and lead to keybinding conflicts (e.g. Super+Up is now set to "Move to workspace above" AND to "Maximize window"). The view splitting shortcuts then usually take precedence, so if I want to switch to another workspace, the window is modified instead.

What could be reason for this restoring of original keybindings and how can I avoid it?

Thanks!

1

First disable the keybindings that conflict in dconf-editor. Then assign these keybindings in your Shelltile Gnome Shell extension.

For example, the "Maximize window" hotkey Up is defined in the key org.gnome.desktop.wm.keybindings maximize. You can use one of two methods to disable this keybinding: using the graphical tool dconf-editor which is not installed by default, or directly changeing the value using a command.

  • Using dconf-editor: once you installed dconf-editor, start it up. Navigate to the key "org", then "gnome", "desktop", "wm", "keybindings", "maximize". Turn off "Use default value", and then edit "Custom value" to read [] rather than the default ['Up']
  • Using the terminal: open a terminal and disable the keybinding with the following command

    gsettings set org.gnome.desktop.wm.keybindings maximize []

You can undo (i.e., set to the default value) with the command

gsettings reset org.gnome.desktop.wm.keybindings maximize []
  • Thanks, this seems to have fixed it. The keybindings for splitting the view were set twice, however, once in org.gnome.metacity.keybindings and once in org.gnome.mutter.keybindings (toggle-tiled-left and toggle-tiled-right). The ones for mutter are probably ignored on my system, but might be effective with other configurations. – Philipp Burch Aug 13 '18 at 6:45
  • Ok, after a week, it looks like this hasn't fixed it yet. It works when I set the keybindings as noted, but after some reboots, those are restored to their default values again. There must be something around that causes this, but how to tell what? – Philipp Burch Aug 20 '18 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.