1

I attempted to upgrade Ubuntu 14 to 16 LTS using sudo do-release-upgrade and everything is broken. The installation is not completed. The logs say it was aborted. When I use apt or apt-get the following output is shown (see below). It seems installation of some packages have left incomplete. All attempts failed.

I managed to chroot into an Ubuntu 16 from CDROM (in fact from HDD) and fixed a few things. But I cannot install the new kernel. (from How to restore a system after accidentally removing all kernels?)

Various things I tried:

  • sudo dpkg --configure t
  • apt-get -f install
  • dpkg -l | grep -v '^ii'|cut -c5-64 >list-of-packages.txt
  • dpkg --configure $(
  • sudo dpkg --configure -a
  • Replaced sources.list with the original file.
  • sudo apt-get install --fix-broken
  • sudo do-release-upgrade # No new release found.
  • ...

Output of uname -a

Linux ubuntu 4.15.0-29-generic #31~16.04.1-Ubuntu SMP Wed Jul 18 08:54:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Output of: ls /etc/apt/sources.list.d

arangodb.list github_git-lfs.list.save
nodesource.list.distUpgrade
staticfloat-juliareleases-trusty.list.distUpgrade arangodb.list.distUpgrade google-chrome.list
nodesource.list.save staticfloat-juliareleases-trusty.list.save arangodb.list.save google-chrome.list.distUpgrade
paolorotolo-droidcam-trusty.list tualatrix-ppa-trusty.list d-apt.list google-chrome.list.save
paolorotolo-droidcam-trusty.list.distUpgrade
tualatrix-ppa-trusty.list.distUpgrade d-apt.list.distUpgrade
google-cloud-sdk.list paolorotolo-droidcam-trusty.list.save
tualatrix-ppa-trusty.list.save d-apt.list.save
google-cloud-sdk.list.distUpgrade rabbitmq_rabbitmq-server.list
ubuntu-toolchain-r-test-trusty.list docker.list
google-cloud-sdk.list.save
rabbitmq_rabbitmq-server.list.distUpgrade
ubuntu-toolchain-r-test-trusty.list.distUpgrade docker.list.distUpgrade linrunner-tlp-trusty.list sbt.list
ubuntu-toolchain-r-test-trusty.list.save docker.list.save
linrunner-tlp-trusty.list.distUpgrade sbt.list.distUpgrade
webupd8team-java-trusty.list erlang-solutions.list
linrunner-tlp-trusty.list.save sbt.list.save
webupd8team-java-trusty.list.distUpgrade erlang-solutions.list.distUpgrade neo4j.list
staticfloat-julia-deps-trusty.list
webupd8team-java-trusty.list.save erlang-solutions.list.save
neo4j.list.distUpgrade
staticfloat-julia-deps-trusty.list.distUpgrade webupd8team-unstable-trusty.list github_git-lfs.list
neo4j.list.save staticfloat-julia-deps-trusty.list.save
webupd8team-unstable-trusty.list.distUpgrade github_git-lfs.list.distUpgrade nodesource.list
staticfloat-juliareleases-trusty.list
webupd8team-unstable-trusty.list.save

sudo dpkg --configure -a Output along list including the following lines:

... dpkg: error processing package libstdc++6:amd64 (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of libkwalletbackend5-5:amd64: libkwalletbackend5-5:amd64 depends on libstdc++6 (>= 5.2); however:
Package libstdc++6:amd64 is not configured yet.

dpkg: error processing package libkwalletbackend5-5:amd64 (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of gstreamer1.0-plugins-good:amd64: gstreamer1.0-plugins-good:amd64 depends on libstdc++6 (>= 4.1.1); however: Package libstdc++6:amd64 is not configured yet. ... Processing was halted because there were too many errors.

The output I get when I do any apt-like command (e.g. sudo apt install linux-image-generic ) is the following:

sudo apt install linux-image-generic Reading package lists... Done Building dependency tree Reading state information... Done You

might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: click : Depends: python3-click (= 0.4.21.1ubuntu0.2) but 6.2-2ubuntu1 is to be installed empathy : Depends: libcheese-gtk23 (>= 3.4.0) but it is not installable Depends: libcogl15 (>= 1.15.8) but it is not installable Recommends: telepathy-haze but it is not going to be installed Recommends: gnome-contacts but it is not going to be installed Recommends: nautilus-sendto-empathy but it is not installable gstreamer1.0-clutter : Depends: libcogl15 (>= 1.15.8) but it is not installable libbaloofiles4 : Depends: libxapian22 but it is not installable libbalooxapian4 : Depends: libxapian22 but it is not installable libc6:i386 : Depends: libgcc1:i386 but it is not going to be installed libgcc1 : Depends: gcc-6-base (= 6.0.1-0ubuntu1) but it is not going to be installed libgfortran3 : Depends: gcc-6-base (= 6.4.0-17ubuntu1~14.04) but it is not going to be installed libgl1-mesa-dri:i386 : Depends: libgcc1:i386 (>= 1:3.4) but it is not going to be installed Depends: libstdc++6:i386 (>= 5.2) but it is not going to be installed libicu55:i386 : Depends: libgcc1:i386 (>= 1:4.2) but it is not going to be installed Depends: libstdc++6:i386 (>= 5.2) but it is not going to be installed libjack-jackd2-0:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed Depends: libstdc++6:i386 (>= 5.2) but it is not going to be installed libllvm3.8v4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed Depends: libstdc++6:i386 (>= 4.8) but it is not going to be installed libllvm6.0:i386 : Depends: libgcc1:i386 (>= 1:4.2) but it is not going to be installed Depends: libstdc++6:i386 (>= 5.2) but it is not going to be installed libmysqlclient18:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed libmysqlclient20:i386 : Depends: libgcc1:i386 (>= 1:4.2) but it is not going to be installed Depends: libstdc++6:i386 (>= 5.2) but it is not going to be installed libqapt2-runtime : Depends: libqapt2 (>= 1.9.60) but it is not installable libqt4-declarative : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-declarative:i386 : Depends: libgcc1:i386 (>= 1:4.2) but it is not going to be installed Depends: libqtcore4:i386 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed libqt4-designer : Depends: libqt4-xml (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-dev : Depends: libqt4-xml (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: qt4-qmake (= 4:4.8.7+dfsg-5ubuntu2) libqt4-dev-bin : Depends: libqt4-xml (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-help : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-network : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-network:i386 : Depends: libgcc1:i386 (>= 1:4.2) but it is not going to be installed Depends: libqtcore4:i386 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed libqt4-opengl : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-opengl:i386 : Depends: libgcc1:i386 (>= 1:4.2) but it is not going to be installed Depends: libqtcore4:i386 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed libqt4-qt3support : Depends: libqt4-xml (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-script : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-script:i386 : Depends: libgcc1:i386 (>= 1:4.2) but it is not going to be installed Depends: libqtcore4:i386 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed libqt4-scripttools : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-sql : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-sql:i386 : Depends: libgcc1:i386 (>= 1:3.0) but it is not going to be installed Depends: libqtcore4:i386 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed libqt4-sql-mysql:i386 : Depends: libgcc1:i386 (>= 1:3.0) but it is not going to be installed Depends: libqtcore4:i386 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed libqt4-sql-sqlite : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-svg : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-test : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-xml:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed libqt4-xmlpatterns : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqt4-xmlpatterns:i386 : Depends: libgcc1:i386 (>= 1:4.2) but it is not going to be installed Depends: libqtcore4:i386 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed libqtcore4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed Depends: libstdc++6:i386 (>= 4.6) but it is not going to be installed libqtdbus4 : Depends: libqt4-xml (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqtdbus4:i386 : Depends: libgcc1:i386 (>= 1:3.0) but it is not going to be installed Depends: libqt4-xml:i386 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libqtcore4:i386 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed libqtgui4 : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed libqtgui4:i386 : Depends: libgcc1:i386 (>= 1:4.2) but it is not going to be installed Depends: libqtcore4:i386 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed Recommends: qt-at-spi:i386 but it is not going to be installed libqtwebkit4:i386 : Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed Depends: libstdc++6:i386 (>= 5.2) but it is not going to be installed libstdc++6 : Depends: gcc-8-base (= 8.2.0-3) but 8.1.0-5ubuntu1~14.04 is to be installed Breaks: libboost-date-time1.54.0 but 1.54.0-4ubuntu3.1 is to be installed Breaks: python-scipy (<= 0.14.1-1) but 0.13.3-1build1 is to be installed libsystemd0:i386 : PreDepends: libgcc1:i386 (>= 1:4.2) but it is not going to be installed libtxc-dxtn-s2tc0:i386 : Depends: libstdc++6:i386 (>= 4.1.1) but it is not going to be installed libubuntu-location-service0 : Depends: libgflags2 but it is not installable Depends: libgoogle-glog0 but it is not installable libudev1:i386 : Depends: libgcc1:i386 (>= 1:4.2) but it is not going to be installed qdbus : Depends: libqt4-xml (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed qt4-linguist-tools : Depends: libqt4-xml (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1 is to be installed ubuntu-system-settings : Depends: qtdeclarative5-ubuntu-settings-components (> 0.7+15.04.20160310) but 0.1+14.04.20140306-0ubuntu1 is to be installed Depends: suru-icon-theme (>= 14.04+15.04.20150813~) but 14.04+14.04.20140410-0ubuntu1 is to be installed Depends: system-image-dbus (>= 3.1) but 2.2-0ubuntu1 is to be installed Depends: ubuntu-keyboard-data (>= 0.99.trunk.phablet2+15.04.20150421) but 0.99.trunk.phablet2+14.04.20140415-0ubuntu1 is to be installed xchat-gnome : Depends: libperl5.18 (>= 5.18.2) but it is not installable zeitgeist-core : Depends: libxapian22 but it is not installable E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

  • 1
    does your /etc/apt/sources.list still contain the trusty ppa entries? libcheese-gtk23, for example is from the trusty repositories, as xenial has the libcheese-gtk25 version. packages.ubuntu.com/xenial/libs/libcheese-gtk25 and packages.ubuntu.com/trusty/libs/libcheese-gtk23 – starkus Aug 12 '18 at 16:21
  • I replaced the contents of sources.list with tje contents at this address: gist.github.com/rohitrawat/60a04e6ebe4a9ec1203eac3a11d4afc1 But I dont know how to check the ppa of libcheese-gtk* – Sohail Si Aug 12 '18 at 19:01
  • 2
    Best practice before a release-upgrade is to uninstall all PPA and other non-Ubuntu software to prevent precisely this kind of situation. Next time, try to return your Ubuntu system to as close to stock condition as possible before starting the release-upgrade. Advice: Backup your data and do a clean install - recovering from a botched release-upgrade is generally not worthwhile. – user535733 Aug 12 '18 at 19:19
2

The repository may have been corrupted. You can use the following command to clean out your apt list:

sudo rm -r /var/lib/apt/lists/*

Then update with

sudo apt update
0

checkout your /etc/apt/sources.list and all files into /etc/apt/sources.list.d/ for duplicates or invalid packages

apt-get clean

and then

apt-get update && apt-get dist-upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.