3

I have a Dell xps 13 (9370) and I'm trying to fresh install Ubuntu 18. Didn't know that developer edition existed. But I can't get the usb to show up in the bios. I know that I partitioned it properly, but I can't figure out why it isn't showing up or being recognized at all.

5
  • Make sure you have followed your computers steps to boot from usb, and did yours come pre-installed with Ubuntu Xenial? Aug 12, 2018 at 15:32
  • No, I got mine with windows. Didn't know you could get it preinstalled with ubuntu. And it simply just doesn't recognize that the usb is there I think. Aug 12, 2018 at 15:55
  • Have you updated UEFI from Dell. How did you create USB flash drive installer? UEFI only USB key, just extract ISO ( 7 zip or similar) to FAT32 formated flash & set boot flag. askubuntu.com/questions/395879/…
    – oldfred
    Aug 12, 2018 at 17:10
  • Just updated the bios and didn't help. I formatted it with RUFUS like they guide says. Formatted as GPD and NTFS cause that's how all the other partitions on my computer are set. Aug 12, 2018 at 17:33
  • Did you try enabling Thunderbolt boot support?
    – Joel Nolan
    Aug 12, 2018 at 20:07

2 Answers 2

3

According to: New XPS 13 (9370) USB Port question

Your laptop will only boot a live USB plugged into the right hand port.

The ports on the left support Thunderbolt 3; the port on the right does not. As a result, the left-hand ports may be disabled at boot time unless you enable Thunderbolt boot support in the BIOS. I would have thought that option would only affect devices that actually try to communicate over the Thunderbolt protocol, but recent threads have indicated that this option also affects whether regular USB-type devices connected to those ports are visible at boot time.

1
  • I CAN'T BELIEVE THIS WAS THE ISSUE Thank you my friend. Now I gotta figure out what to do now that it's booting to grub XD Aug 13, 2018 at 0:06
0

Disbale the secure boot in BIOS and change the boot mode to legecy. You will these options in BIOS->BOOT tab. After changing the setting restart your system and go in boot menu. You will find your usb option there.

6
  • Nope, didn't show up after setting it to legacy. Aug 12, 2018 at 15:49
  • Have you check if the usb is bootable? Aug 12, 2018 at 16:02
  • It works on my old hp (runs into GNU GRUB boot error), but still is the first thing when I changed the boot order. Aug 12, 2018 at 16:24
  • Try changing the boot priority and set usb at first and then hdd/ssd at second Aug 12, 2018 at 16:33
  • 3
    You still want to boot Ubuntu installer in UEFI mode, since Windows is UEFI.
    – oldfred
    Aug 12, 2018 at 17:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.