31

I'm having a problem with Nautilus, showing an alphabetical list of files and folders. Obviously, an option to list folders first then files, is gone. I noticed listing order change after some upgrade (hard to say now, which one was that):

enter image description here

I was trying the solution proposed here: Nautilus: Make “Show folders before files” option persist?, with no luck. I do not notice the permission problems when starting Nautilus from the bash. Is there any magic configuration setting to change the listing for Folders First?

43

You can change this from the Nautilus preferences. Open the context Menu from the top-right of a Nautilus Window:

Nautilus Context Menu

Tick 'Sort folders before files'. Nautilus Preferences

If that doesn't work you can edit the Dconf file directly, the easiest way is using the Dconf Editor: Install Dconf Editor (sudo apt install dconf-editor), open it and then navigate to:

orggtksettingsfile-choosersort-directories-first and set it to True.

dconf editor

Alternatively, run this command in the terminal:

dconf write /org/gtk/settings/file-chooser/sort-directories-first true
| improve this answer | |
  • 1
    This doesn't work on 18.10 sadly. – Jan Hančič Nov 4 '18 at 11:52
  • @JanHančič I have just tested this with 18.10, it's enabled by default and does work, how did you test it? – Hugo Nov 4 '18 at 17:43
  • 2
    Apologies, I've just tried it again and it does indeed work! I think I forgot to re-open the file browser the first time around. – Jan Hančič Nov 11 '18 at 13:37
  • Do not run dconf-editor as sudo – Gerard Carbó Jan 23 at 10:35
  • Works fine on 18.04.4, without restarting the file manager – Sam Apr 23 at 11:52
8

It is also possible to use the pre-installed gsettings command line utility for that:

gsettings set org.gtk.Settings.FileChooser sort-directories-first true

The current setting can be checked like this:

gsettings get org.gtk.Settings.FileChooser sort-directories-first
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.