11

I am trying to get Citrix receiver to work on my Ubuntu laptop. I've installed the Citrix receiver, however when I try to open the .ica file that my company provides when I login to my organisation's Citrix StoreFront site by Chrome, it exits out with an error that states "Cannot connect to 0.0.02 - Windows 2016 Desktop. No such file or directory. Verify your connection settings and try again". After this, the .ica file gets deleted automatically.

In addition, if I try to enter the address of my organisation's Citrix StoreFront site directly in the installed app, it gives me this error; "Your account cannot be added using this server address. Make sure you entered it correctly. An SSL connection to the server couldn't be established because the server's certificate was not trusted."

I always have to switch to Windows to work remotely. I tried every available solution existed on the internet including First Link, Second Link. I guess my problem is somehow related to wildcard character in my company's certificate. It is issued to * .myCompanyName however the site address is door.myCompanyName

I tried everything. I don't want to switch to Windows just because of this. Please help me.

21

This sounds like a problem with the certificates shipped with the Citrix client for Linux (screenshot). An elderly article in the Ubuntu Community Wiki explains:

Citrix Receiver only trusts a few root CA certificates, which causes connections to many Citrix servers to fail with an SSL error. The 'ca-certificates' package (already installed on most Ubuntu systems) provides additional CA certificates [...] that can be conveniently added to Citrix Receiver to avoid these errors

The Citrix client has its certificates installed in /opt/Citrix/ICAClient/keystore/cacerts. You can safely remove the entire folder and add a symbolic link to /etc/ssl/certs instead:

$ cd /opt/Citrix/ICAClient/keystore/
$ sudo rm -r cacerts
$ sudo ln -s /etc/ssl/certs cacerts

The Citrix Receiver will start to work just fine afterwards.

  • 1
    it does not work for me :( – Reza Oct 3 '18 at 7:52
  • Same here, still getting the error. – Cameron Sima Dec 19 '18 at 19:45
  • This delays giving up (I see a status bar now for ½ a seconds) but does not solve it (when double-clicking .ica-files). ––– What binary should I call those .ica files from the command line? Somewhere in /opt/Citrix/ICAclient/... I assume. And is there a switch for verbose mode for that binary? (to hopefully get a bit more detail) – Frank Nocke Jan 3 '19 at 14:15
  • 1
    @FrankNocke When you install the .deb from the Citrix website the ELF binary is installed in /opt/Citrix/ICAClient/wfica. It doesn't seem to provide any switch for verbosity (run wfica -h to see the help screen yourself). There's also a wfica.sh script in the same directory that can give you some clues. – Peterino Jan 3 '19 at 22:53
  • Worked for me, with Citrix Workspace app 18.10 (18.10.0.11_i386). – Marten Koetsier Jan 9 '19 at 21:20
1

Makes Citrix Workspace Work on Chrome Browser running on Ubuntu MATE 18

$ uname -a
Linux 5.0.0-37-generic #40~18.04.1-Ubuntu SMP Thu Nov 14 12:06:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Steps

  1. Export CA from browser little lock icon when visiting storefront.example.com

    reference
    aside: I found it easier to export CA with Firefox than Chrome

  2. Import CA to browser

    In Chrome: chrome://settings/advance

  3. Set the CA in Linux

    • Copy your CA to the directory /usr/local/share/ca-certificates/
    • Use command:

      sudo cp <whatever>.crt /usr/local/share/ca-certificates/<whatever>.crt
      
    • Update the CA store:

      sudo update-ca-certificates
      
    • fun aside, use openssl to check the certificate

  4. Follow steps above

    cd /opt/Citrix/ICAClient/keystore/
    sudo mv cacerts _cacerts  ### I don't delete things until things are working
    sudo ln -s /etc/ssl/certs cacerts
    

Notes Below for Search Bots

Error Message for Firefox

$ firefox --version
Mozilla Firefox 68.0.1

Submitting details on the storefront.example.com page returned an error log while using FF Quantum

Citrix Workspace app cannot launch desktop "example Desktop"

Please verify that the ICA connection is available and that the server address is present


Different Error Message with Chrome

Brave - Version 1.1.21 Chromium: 79.0.3945.79 (Official Build) (64-bit)

  1. have to navigate to the storefront storefront.example.com
  2. select
  3. file *.ica is created (screenshot)
  4. double click donwloaded *.ica file
  5. get error message

[SSL ERROR]

Contact your help desk with the following information: You Have not chosen to trust "AddTrust External CA Root", the issuer of the server's security certificate (SSL error 61)

0

Well, I've found a way for connecting to the server in Chrome. When you log in to the company's website, click on your name on top-right corner of Chrome then click on "Change Citrix Receiver..." and finally click on using light version instead of using full version. But still cannot connect with application.

0

This really worked for me: copy the CACerts from Mozilla.

sudo cp --verbose /usr/share/ca-certificates/mozilla/* /opt/Citrix/ICAClient/keystore/cacerts/

Then download your .ica from Mozilla.

See the SuperUser thread: How do I install Citrix ICA client receiver 13 on Debian 64-bit Linux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.