9

I am trying to get Citrix receiver to work on my Ubuntu laptop. I've installed the Citrix receiver, however when I try to open the .ica file that my company provides when I login to my organisation's Citrix StoreFront site by Chrome, it exits out with an error that states "Cannot connect to 0.0.02 - Windows 2016 Desktop. No such file or directory. Verify your connection settings and try again". After this, the .ica file gets deleted automatically.

In addition, if I try to enter the address of my organisation's Citrix StoreFront site directly in the installed app, it gives me this error; "Your account cannot be added using this server address. Make sure you entered it correctly. An SSL connection to the server couldn't be established because the server's certificate was not trusted."

I always have to switch to Windows to work remotely. I tried every available solution existed on the internet including First Link, Second Link. I guess my problem is somehow related to wildcard character in my company's certificate. It is issued to * .myCompanyName however the site address is door.myCompanyName

I tried everything. I don't want to switch to Windows just because of this. Please help me.

19

This sounds like a problem with the certificates shipped with the Citrix client for Linux (screenshot). An elderly article in the Ubuntu Community Wiki explains:

Citrix Receiver only trusts a few root CA certificates, which causes connections to many Citrix servers to fail with an SSL error. The 'ca-certificates' package (already installed on most Ubuntu systems) provides additional CA certificates [...] that can be conveniently added to Citrix Receiver to avoid these errors

The Citrix client has its certificates installed in /opt/Citrix/ICAClient/keystore/cacerts. You can safely remove the entire folder and add a symbolic link to /etc/ssl/certs instead:

$ cd /opt/Citrix/ICAClient/keystore/
$ sudo rm -r cacerts
$ sudo ln -s /etc/ssl/certs cacerts

The Citrix Receiver will start to work just fine afterwards.

  • 1
    it does not work for me :( – Reza Oct 3 '18 at 7:52
  • Same here, still getting the error. – Cameron Sima Dec 19 '18 at 19:45
  • This delays giving up (I see a status bar now for ½ a seconds) but does not solve it (when double-clicking .ica-files). ––– What binary should I call those .ica files from the command line? Somewhere in /opt/Citrix/ICAclient/... I assume. And is there a switch for verbose mode for that binary? (to hopefully get a bit more detail) – Frank Nocke Jan 3 at 14:15
  • 1
    @FrankNocke When you install the .deb from the Citrix website the ELF binary is installed in /opt/Citrix/ICAClient/wfica. It doesn't seem to provide any switch for verbosity (run wfica -h to see the help screen yourself). There's also a wfica.sh script in the same directory that can give you some clues. – Peterino Jan 3 at 22:53
  • Worked for me, with Citrix Workspace app 18.10 (18.10.0.11_i386). – Marten Koetsier Jan 9 at 21:20
0

Well, I've found a way for connecting to the server in Chrome. When you log in to the company's website, click on your name on top-right corner of Chrome then click on "Change Citrix Receiver..." and finally click on using light version instead of using full version. But still cannot connect with application.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.