0

Title pretty much says it all. lspci -v finds a sound card, but neither aplay -l not pacmd list-cards don't. Problem first surfaced when updating ubuntu to 18.04, which was a hail-mary attempt to fix an another probably unrelated issue with my login screen. I'm not sure whether or not my sound was working before the ubuntu update either, since the login screen issue arose when I got my machine back from warranty repair.

Alsa self diagnose: https://pastebin.com/787EwmQC

lspci -v: https://pastebin.com/K52mA74m

aplay -l: aplay: device_list:270: no soundcards found...

pacmd list-cards: 0 card(s) available.

Things to note:

  • My boot time lasts a bit longer than I remember it lasting, maybe some kernel module thing fails?
  • My pulseaudio daemon doesn't start on boot. Maybe unrelated but I think you should know.
  • I'm running the newest ubuntu (18.04).

Have tried:

  • Reinstalling many things, some probably multiple times.
  • Robooting with various changes
  • Deleting the local pulseaudio config in ~/.config/pulse
  • reseting default.pa (might have picked the wrong one to reset to)
  • Adding myself to audio group

EDIT: inxi -a sees the card and states that it's using the snd_hda_intel driver.

  • snd_soc_skl: Unknown symbol snd_hdac_...: your sound modules were not compiled correctly. You did not mention that you are not using the standard drivers. – CL. Aug 11 '18 at 10:40
  • To be completely frank, I wasn't aware of that. How do I switch back to standard drivers? – eero häihälä Aug 11 '18 at 10:45
  • Who is administrating this machine? If it's you, try repairing (or updating) the kernel package. – CL. Aug 11 '18 at 12:30
0

Grayfade from linux discord:

Try this, but I have no idea if it'll work:

EDITOR=nano sudoedit /etc/modprobe.d/intel.conf

Add these lines and save: options snd-hda-intel single_cmd=1 options snd-hda-intel probe_mask=1

Reboot. If it does work, I have no idea why.

It worked, neither of us know why. Source of commands: No sound on Ubuntu 15.10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.