0

Hey so I have downloaded this (clicking on this hyperlink downloads) http://cs-people.bu.edu/sameki/LabelMe.zip into ubuntu via command line, and I go to the folder to find a run.sh to run. But when I run it says another file loadHITS.sh not found.

What do I do when I have such error? I'm working first time with ubuntu etc. I'm just following instructions from a PDF

EDIT: The PDF I'm working with is this - http://cs-people.bu.edu/sameki/blog1.pdf

  • 2
    Did you extract the archive? Please edit and add the output of ls -l. – dessert Aug 10 '18 at 22:50
  • 1
    Have you downloaded something else that you wish to use this in conjunction with? These scripts are meant to be run from inside a directory that is inside a directory containing the "missing" scripts (in a folder called bin)... – Joshua Besneatte Aug 10 '18 at 22:51
  • You may well need to run chmod a+x ./loadHITS.sh && ./loadHITS.sh or cd into the directory containing loadHITS.sh and / or use the full path to loadHITS.sh . Cant tell from what you posted – Panther Aug 11 '18 at 2:04
  • Please post the exact error text or better yet whole output from run.sh script. Additionally, the pdf instructions you mentioned would be great to add, too. – Sergiy Kolodyazhnyy Aug 11 '18 at 3:15
  • Hey @JoshuaBesneatte so I found something called loadHITs.cmd not loadHITs.sh, but it was another level up than what you said. Should I just move my current downloaded document(this zip) by one folder up? many thanks! – ai_boy Aug 11 '18 at 18:35
0

Looking at the script, there seems to be much more to it. It appears to be a folder that is to be placed somewhere where these scripts exist. Have you installed or downloaded something that these scripts are meant to work with?

When the script runs, it tries to go up two directories and look for a folder called bin, where the scripts are to be located.

First you need to see if you have this file somewhere on your system. You can use locate from the command line:

sudo apt install locate
sudo updatedb
locate loadHITs.sh

If you can locate this file on your system, or post what you find and I can tell you where to place the folder so that it will work. Otherwise you will need to find the necessary scripts to work in conjunction with this set of scripts.

| improve this answer | |
  • Hey I have tried it, there is no loadHITs.sh anywhere. So I'm working with amazon Turk, and basically what this zip file should do is integrate my server to the Turk. The PDF I'm following instructions from is this - cs-people.bu.edu/sameki/blog1.pdf. If you look at the end of PDF it says to put the above Hyperlink into the aws-mturk directory. As per what you said, there was no loadHITs.sh anywhere even in above directory. Any chance the loadHITs.sh is 'created'? Thanks for the reply!! – ai_boy Aug 11 '18 at 18:30
  • from a quick look at that pdf you need to install turk command line tools.... and either the server needs to look to your secure server to pull the lable me files or you need to install the turk command line tools aws.amazon.com/developertools/Amazon-Mechanical-Turk/694 – Joshua Besneatte Aug 11 '18 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.