I have a LED that can play media from USB, I have 2 USBs 4GB and 32GB, LED picks up 4GB but it detects 32GB but didn't show the content of USB. The Vendor says it issues with USB partition system.

Here is 4GB partitions details,

enter image description here

and 32 GB, enter image description here

I tried deleting all partition on 32GB and create new FAT32 as well as NTFS, but it didn't create the same as I had on 4GB,

Any solutions?

  • 1
    I think it's talking about the partition table not the partitions themselves, this disk is formatted as GPT, the device might only be able to handle MBR / msdos type partition tables
    – Thomas Ward
    Aug 10, 2018 at 20:28
  • How can i create of such type partitions tables? Aug 10, 2018 at 20:30

1 Answer 1


Try these steps:

  1. Open a terminal and run this command to locate the right device:

  2. Use fdisk command accordingly:

    1. sudo fdisk /dev/sdX; X stands for the right disk letter something in the region of b, c or d
    2. Type o to change the partition table type to dos
    3. When the command runs type d and enter to delete the existing partition, then
    4. Type n to create new partition
    5. Accept the defaults when ask for the partition type and size (assuming that is desirable),
    6. Type p to see what you have done,
    7. Type t to change the file system type,
    8. Type c to create a W95 FAT32 (LBA) partition,
    9. Repeat step 2.5, i.e. 5 above to see the created partition,
    10. Type a to activate that partition so it automounts,
    11. Type w to write the changes to disk
  3. Format the again from the terminal:

    sudo mkfs.vfat /dev/sdXi
    • Note: i represents the partition number in this case it should be 1
  4. Eject and replug the device

NOTE: This will destroy any data on the said device e please back up anything you wish to keep before following theses steps.

  • Make a note that this will destroy all data on the USB stick, so copy any data you want to keep off of the stick first BEFORE you follow this answer.
    – Thomas Ward
    Aug 11, 2018 at 4:10
  • I don't see where you change the disk-label from GPT to msdos or is this done automatically by fdisk?
    – mook765
    Aug 11, 2018 at 6:23
  • @mook765 thanks for the heads up, updated the answer accordingly... Aug 11, 2018 at 7:15
  • Thx for this. I was choosing the wrong type and/or part table when I was trying to get something to work. Even tried it in Windows. Not sure why I was blind to option c in the list.
    – ekeyser
    Oct 25, 2021 at 16:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .