I am running Lubuntu 18.04 on my computer. I was curious and accidentally changed the desktop environment from lxde to lxqt in the login screen. I don't have lxqt installed. It shows me a black screen . Please help me to change back to lxde

closed as off-topic by DK Bose, user535733, George Udosen, N0rbert, Melebius Aug 14 at 9:27

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – DK Bose, user535733, George Udosen, N0rbert, Melebius
If this question can be reworded to fit the rules in the help center, please edit the question.

There shouldn't be any lxqt session in the login screen unless you've done something which you haven't reported.

The default choices are:

  • Lubuntu
  • Lubuntu Qt session
  • Openbox

Default login choices

The contents of /usr/share/xsessions/QLubuntu.desktop are:

[Desktop Entry]
Name=Lubuntu Qt session
Comment=A specific Lubuntu session using Qt
Exec=/usr/bin/startlxqt
Type=Application

Running

locate startlxqt  

comes up empty.

And when a user chooses to login with Lubuntu Qt session, the following window pops up:

startlxqt not found

The only option is to click Okay after which the system crashes.

In my opinion, Lubuntu Qt session shouldn't have been present at all. It just doesn't work. You most probably will have to reboot as suggested by Panther in a comment to your question.

When you do reboot and reach the login screen, carefully click on the image to the left of en_US (or whatever language choice you have) and carefully choose Lubuntu because if you don't the likelihood is that you'll again end up with the Lubuntu Qt session because the last choice is remembered.

Once you're safely logged in, if you want to ensure you never accidentally click on the Lubuntu Qt session again, open your terminal and run the following commands:

cd /usr/share/xesssions
sudo rm QLubuntu.desktop 

The next time you login, you won't see Lubuntu Qt session as an option.

Lubuntu Qt session removed


Update This issue has been addressed and a fix is committed: https://bugs.launchpad.net/ubuntu/+source/lubuntu-default-settings/+bug/1786602/comments/2

  • I have used lxqt on fedora for 2 years, I like it more than lxde, but I am not familiar lubuntu – Panther Aug 10 at 17:03
  • I'm using it on Lubuntu 18.10. It's decent there. But not on Lubuntu 18.04. I have the same experience as OP :( – DK Bose Aug 10 at 17:05
  • @Panther, I've edited the answer to provide the contents of QLubuntu.desktop which is the problematic one. It tries to execute /usr/bin/startlxqt which does not exist. – DK Bose Aug 11 at 10:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.