I'm having a problem since I installed Ubuntu 18.04 over 16.04. I have a connection that gives me a lot of trouble, randomly fails and needs me to run sudo service network-manager restart to work. I read somewhere that the problem could be solved by disabling IPv6 authentication for this connection. I wanted to do that, but whenever I go in WiFi settings, there's an icon of a lock next to the connection, and I can't edit them. I can change things but there's no Apply or OK button, so I can't save the changes. I assume this is because the connection is locked under admin privileges or as an other user, except I only have one user on this computer, and there's no clear way to just input my password and get the authorisation. I tried launching gnome-control-center from the terminal with sudo and all I got was that the window was empty and with no options. Any ideas on what should I do? Thanks!

  • Login as administrator – user857648 Aug 10 '18 at 21:25

I was having the same problem and I figured it out while reading your post. I launched the connection editor through the terminal instead of from the applet


Then when I tried to edit the wifi network that was giving me trouble, I saw this error message.

** Message: 17:41:57.649: Cannot save connection due to error: Invalid setting Wi-Fi Security: No certificate set

Checking the "No certificate required" box under the "Wifi Security" tab allowed me to finally save the configuration.

No idea if disabling IPv6 is going to solve my disconnect issues yet, but at least I was able to save the changes!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.