I typed the command

sudo gedit /etc/bash.bashrc 

And typed the export statement as

export http_proxy="username: password@proxyhost:port"

But after saving it gave a warning message as

set document meta data failed 
gedit spell language not supported
gedit encoding not supported
gedit position not supported

When I try apt-get update it still shows proxy authentication error

You can try installing cntlm to automatically handle your proxy settings:

supo apt install cntlm
sudo nano /etc/cntlm.conf 

From here edit the following fields to give your credentials:

Username username
Domain proxydomain
Paswword pwd 

[...]

Proxy proxyaddress:3128
Noproxy localhost, 127.0.0.*, 10.*, 192.168.*
Listen proxyport

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.