3

I'm using QEMU with KVM in virt-manager, with a Windows 10 guest. I've noticed the audio to be very choppy, and will cut in and out constantly. After installing most of the virtio drivers for Windows, and trying all the different sound device options shown in virt-manager, I still get the same choppy audio. My host is Ubuntu 18.04, and I'm using headphones through a standard 3.5mm headphone jack. This issue does not occur when listening to audio on the host, or when listening to audio from another Linux Guest. I've tried searching for virtio sound drivers, but haven't had any luck. Has anyone else encountered this problem? And if so, are there any solutions?

EDIT: I'm using a SPICE server for video output, and connecting to my local machine (localhost).

1
  • 1
    I'm using SPICE right now. I haven't tried any other display outputs. – wispi Aug 10 '18 at 7:35
0

I tried the ich6 and ich9 and had the same issue with a Windows 7 guest. I then switched to the old ac97 type, installed the hardware-driver for this in the Windows guest, and the constant skipping-audio stopped.

That said, I do still get the occasional sound-glitch, which I am attempting to solve with setting the VMM-processes to a higher priority (nice setting) in the host-machine. "Pinning" CPUs is also recommended (so the VMM has exclusive use of them).

More research suggests the only low-latency, good solution is to use a USB sound-device, passing this through to the guest, and ensure that device supports USB-reset (which, I am guessing, is an event which occurs when the device is passed from host to guest).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.