1

I have a dell XPS 15 (9560) and I've installed an intel wireless AC 9260 WiFi card. I'm running ubuntu 18.04 with kernel 4.17.14-041714-generic. I get very realiable wifi connections, but it's extremely slow. After some testing, I found that it won't connect at a link speed higher than 54mb/s as reported in the gnome network manager applet.

I think for some reason the card is connecting at G speeds. The strange thing is my access point is set to WiFi A/N only on the 5GHz band so it shouldn't be possible. I've tried a lot of different askubuntu answers. The access point is set to only allow AES encryption. An interesting thing is this excerpt from iw list:

...
Band 2:
    Bitrates (non-HT):
        * 6.0 Mbps
        * 9.0 Mbps
        * 12.0 Mbps
        * 18.0 Mbps
        * 24.0 Mbps
        * 36.0 Mbps
        * 48.0 Mbps
        * 54.0 Mbps
    Frequencies:
        * 5180 MHz [36] (22.0 dBm) (no IR)
        * 5200 MHz [40] (22.0 dBm) (no IR)
...

It appears Ubuntu thinks the card can only do up to 54mb/s. My Galaxy S9+ connects fine at 300mpbs+ so I don't believe it's an access point issue. Any idea how I can get a connection speed above 54mb/s? Thanks heaps!

UPDATE:

After a recent string of updates it seems to have fixed itself.

2 Answers 2

1

It appears Ubuntu thinks the card can only do up to 54mb/s.

Not Ubuntu. It is the driver; the support for your card is fairly new (it was added to debian july 2018) so it might just be lacking support for this.

2 things to try:

On ubuntuforums there is a suggestion ...

  • you need this patch.
  • try the option 11n_disable=1 or 11n_disable=8in /etc/modprobe.d/iwlwifi.conf

I would file a bug report on this against linux-firmware iwlwifi.

0

I'm running on an XPS15 9570 with the same Intel 9260 Card and noticed the same behavior.

In my own testing, nothing worked for me until I updated the kernel to baseline 4.16.x and performance was restored to normal. Haven't tested with 4.17.x.

Give 4.16 a try and see if it works for you.

Note: The main downside of updating the kernel for me was breaking from 18.04LTS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .