1

I have a newly installed version of Ubuntu 18.04 dual booted with Windows 10. Setup went great and I've had no issues using Ubuntu. However, when I turn on my computer and boot into Linux, my mouse pointer will not move. I have a mouse that lights up when it is powered on and when it is not working I noticed the lights are off. It seems that it isn't even getting power when this happens. To fix this, I just turn the computer off and back on again then the mouse has power and everything is fine. When I boot into Windows 10, the mouse always works. It has become a common enough occurrence that I have power cycle again, after turning it on initially, on a daily basis just to get the mouse working.

I have a Razor Naga USB mouse. The keyboard (also USB) doesn't seem to be effected. The mouse is using the USB in the back of the computer (as opposed to a USB hub or additional port on the keyboard).

Has anyone had this issue? How would I even go about troubleshooting this? I'm not familiar with investigating system level failures (like USB drivers for example) in Linux.

Update: dmesg output:

[    1.792881] [drm] Finished loading DMC firmware i915/skl_dmc_ver1_26.bin (v1.26)
[    1.797053] usb 1-8: New USB device found, idVendor=0d8c, idProduct=0012
[    1.797054] usb 1-8: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    1.797055] usb 1-8: Product: USB Audio Device
[    1.797056] usb 1-8: Manufacturer: C-Media Electronics Inc.
[    1.928008] usb 1-9: new full-speed USB device number 5 using xhci_hcd
[    2.061261] [drm] failed to retrieve link info, disabling eDP
[    2.064752] [drm] Initialized i915 1.6.0 20171023 for 0000:00:02.0 on minor 1
[    2.077201] usb 1-9: unable to read config index 0 descriptor/all
[    2.077203] usb 1-9: can't read configurations, error -71
[    2.204069] usb 1-9: new full-speed USB device number 6 using xhci_hcd
[    2.256394] checking generic (d1000000 300000) vs hw (b0000000 10000000)
[    2.256447] i915 0000:00:02.0: fb1: inteldrmfb frame buffer device
[    2.354338] usb 1-9: string descriptor 0 read error: -71
[    2.354342] usb 1-9: New USB device found, idVendor=1532, idProduct=001f
[    2.354343] usb 1-9: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    2.355456] usb 1-9: can't set config #1, error -71
[    2.480295] usb 1-14: new full-speed USB device number 7 using xhci_hcd
[    2.629969] usb 1-14: New USB device found, idVendor=1532, idProduct=021e
[    2.629984] usb 1-14: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    2.629985] usb 1-14: Product: Razer Ornata Chroma
[    2.629986] usb 1-14: Manufacturer: Razer

After I disconnect and reconnect the mouse:

[ 1436.941950] usb 1-9: USB disconnect, device number 6
[ 1446.504530] usb 1-9: new full-speed USB device number 8 using xhci_hcd
[ 1446.654938] usb 1-9: New USB device found, idVendor=1532, idProduct=001f
[ 1446.654941] usb 1-9: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1446.654944] usb 1-9: Product: Razer Naga Epic
[ 1446.654946] usb 1-9: Manufacturer: Razer
[ 1446.656777] input: Razer Razer Naga Epic as /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.0/0003:1532:001F.0006/input/input28
[ 1446.657065] hid-generic 0003:1532:001F.0006: input,hidraw5: USB HID v1.11 Mouse [Razer Razer Naga Epic] on usb-0000:00:14.0-9/input0
[ 1446.657984] input: Razer Razer Naga Epic as /devices/pci0000:00/0000:00:14.0/usb1/1-9/1-9:1.1/0003:1532:001F.0007/input/input29
[ 1446.716997] hid-generic 0003:1532:001F.0007: input,hidraw6: USB HID v1.11 Keyboard [Razer Razer Naga Epic] on usb-0000:00:14.0-9/input1

Using this command:

strings /usr/src/linux-headers-4.15.0-38-generic/include/uapi/asm-generic/errno.h

I found what error code -71 is: EPROTO 71 /* Protocol error */

But I still don't know what this really means... and how to fix it.

0

you can try this : sudo modprobe -r psmouse

  • 1
    How does removing the mouse module help? – Nathan Thompson Aug 19 '18 at 23:36
0

This removes the mouse. If you run the above command by mistake, run this: sudo modprobe -a psmouse

  • 1
    and what happens after running that cmd? – Pierre.Vriens Oct 28 '18 at 13:26
0

I had the same problem using a Razer Diamondback 2 mouse on openSUSE Tumbleweed and was able to fix it. I've included a description on how I solved the problem below, since I'm not using Ubuntu and as the problem seems to be very hardware specific.

tl;dr: Add the line following line to /etc/modprobe.d/50-blacklist.conf:

blacklist mt76x2u

How to make sure the solution works for you:

It seems to be a problem with a MediaTek's mt76x2u firmware driver. Loading the driver seems to result in a page fault if the Razer device is plugged into USB 3 (at least that's what happened to my mouse and keyboard).

You should probably make sure first that you've got the same problem. dmesg | grep mt76x2u got me several lines, including these two:

[   10.367973] mt76x2u 5-4.2:1.0: firmware upload timed out
[   15.552552] mt76x2u: probe of 5-4.2:1.0 failed with error -5

You should also see similar errors in journalctl.

Once you've made sure that you have the same problem, you just need to disable the driver. It was recently added to linux-firmware, and everything worked fine for me before, so I concluded that I just don't need it.
Find your modprobe blacklist. For me it's /etc/modprobe.d/50-blacklist.conf, but appearently its /etc/modprobe.d/blacklist.conf on some other distributions. Then blacklist the kernel module by entering the line blacklist mt76x2u, save and reboot.

  • 1
    Thanks for your suggestion. It appears I do not have the same problem that you have, but I was able to find the info in dmesg that describes what is going on. I've updated my question with the information. – Nathan Thompson Nov 19 '18 at 16:03
0

this works for me

change in /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.synaptics_intertouch=0"

then

sudo update-grub

then shutdown and restart

  • 1
    Isn't "synaptics" the mousepad on a laptop? I'm not using a laptop, this is a desktop with only the USB mouse, no touchpad. – Nathan Thompson Jul 17 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.